Skip to Content
avatar image
Former Member

BO Explorer: Indexing error

Dears!

I am pretty new with BO Explorer and we have been experiencing for some weeks (over a month) an indexing process issue: it fails to run.

The error message is the following:

Server xxxxxxx generated the following messages:

Index Creation Failed (while trying to invoke the method com.businessobjects.datadiscovery.dataprovider.lucene.exploration.result.ILuceneMember.getKey() of a null object loaded from local variable 'member')

The amount of data is quite huge and the number of columns as well. 9 millions of records for 59 facets and 4 Measures.

SAP is unabled to give an answer (this high priority case has been raised 2 weeks ago already and still almost no releavant answer).

We tried to split the data into 2 views and it worked.

Removing some detailed facets works also but it is not a satisfying solution as the customer does want to see all of them at a glance.

I would really appreciate any input which would help to resolve our problem!

Thanks a lot.

Cyril.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Oct 30, 2015 at 12:46 PM

    Cyril,

        Some question to help:

    • BI4 environments details.  # of explorer servers, cluster ?
    • Using UNV &/or UNX
    • Database source and ODBC driver version
    • Location of FRS ? (SAN, Local ? , Space for DATA folder

    9 Mil records is nothing if Explorer is configured properly.  I have customer retrieving well over 20Mil records every night and viewing Explorer via browser and Mobile.

    Regards,

    Ajay

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ajay Gupta

      Hi Ajay,

      thanks again for your answer.

      We will try to export then the data to flat file on the server and to index the data based on this file.

      I do not close yet the topic and I will get back to you as soon as possible;

      You are great thanks a lot!

      Cyril.

  • avatar image
    Former Member
    Nov 04, 2015 at 07:41 AM

    Hi Ajay,

    I have created an open hub to extract the data from the DSO to a flat file (CSV) and we tried to create an ODBC driver on top of it and to create an Universe using this ODBC. It did not work (connection test failed).

    The same for a universe directly based on the CSV file. The file is too huge to be opened in any client tools we do possess...


    I do not see any solution here...

    Thanks!

    Cyril.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 14, 2015 at 08:13 PM

    I had a similar issue but with a smaller set and it simply did not like the set of calculated measure objects from the Bex/UNV.

    I created the calculated measures in Explorer and only bring over the non-calculated results.  Only then did the Index was successful.

    *edit*

    After rereading your environment.  It's similar to ours, SAP BW but we implement BEx then UNV -> Explorer.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 18, 2015 at 06:56 AM

    Hi Jayson,

    We do not have any calculation in the universe. This is what is weird.

    But as a general rule we are facing extremely big performances problem accessing a couple of millions of records.

    We did not succeed yet to get the full scope in Explorer. We are forced to do some filters.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      AAhhh.  I agree requiring to filter down the results.  Even split up the Workspace into sectional reports.

      Personally I feel it's simply the wrong tool to handle that volume to perform unbound exploration/simply analytics.

      I'd suggest trying Lumira if the license is available or Design Studio since they're the products coming in 4.2 to replace Explorer and Dashboard Designer.  I haven't had hands on Lumira yet so I can't say with confidence it'll handle that volume better than Explorer does.  I've had DS hands on and it's a nice nifty tool that only lacks a few user interface objects compared to Dashboard D and doesn't have the limitations of the Excel component.

      Just food for thought, sorry I haven't more to help with your Explorer issue Cyril.

  • Feb 04, 2016 at 01:46 PM

    Hi Cyril,

    I reactivate this subject in order to have more info about your issue.

    You create UNV on BW datasource. You have a lot of dimensions (59) and few measures (4).

    1-Question : do you know, approximately, the total number of distinct values for dimensions ?

    You said you removed some detailed facets to work.

    2-Question : What do you mean with 'detailed facet' ? any particular/special dimension ?

    You have 2 Explorer servers :

    3-Question : do you mean that you have 2 x 4 Explorer servers (index, exploration, search, master) running in the same SIA while indexing ?

    FYI: When you use UNV/UNX then Explorer indexes all metadatas + values (dim names, dim values, measure names) into indexes files.When you use BWA or HANA, only metadatas are indexed.

    So I try to identify if your issue is due to capacity issue or else....

    Regards,

    Add comment
    10|10000 characters needed characters exceeded