Skip to Content

Issues with Fiori Add-on SAP_UI SP14

Hello experts,

We have implemented Fiori as embedded deployment in an SAP NW 740 (with EHP7 for SAP ERP 6.0) system running on HANA DB. The SAP_UI version is SP14 and the SAPUI5 library version is 1.28.19.

We have recently upgraded the SAP_UI component from SP12 to SP14, after doing this we have implemented the SAP Notes (those which were applicable for our system) mentioned in this blog SAP Fiori - UI Add-on SP14 notes list, SAPUI5 library 1.28.18.

After this whenever we open any app from the launchpad the app does not open, we just keep seeing the loading (flower) image infinitely as shown below.

We also do not see any error message in the browser console. We have started noticing this behavior after upgrading SAP_UI to SP14. We have also applied SAP Note 2230554 which seemed relevant for this issue, but even after this the issue persists.

Can anyone let us know how we can go about finding out the root cause for this and resolve this issue? This is a critical issue for us since before applying SP14 of SAP_UI the apps were working fine.

Regards,

Saurabh

SMHError.png (31.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 30, 2015 at 08:28 AM

    Hi Saurabh;

    Is it happening for all the users or for some specific user.

    Is launchpad designer working fine?

    Have you tried clearing the cache after applying the notes.Please try to clear the cache and then try again.

    1. Report /UI2/INVALIDATE_GLOBAL_CACHES (clear the cache)

    2.Clear the server http cache

    Go to the transaction SMICM. Goto -> HTTP plugin -> Server cache -> Invalidate Locally and Globally.

    3. Clear metadata cache

    Transaction: /IWFND/CACHE_CLEANUP on Gateway

    Transaction: /IWBEP/CACHE_CLEANUP on Backend and Gateway

    4. Synchronize chip cache

    Run the report /UI2/CHIP_SYNCHRONIZE_CACHE. Make sure there is no error in the table /UI2/CHIP_CHDR

    Run the report /UI2/DELETE_CACHE_AFTER_IMP.

    /UI2/DELETE_CACHE

    5. Run cache buster

    Run the report /UI5/UPDATE_CACHEBUSTER.

    6. Clear local browser cache

    Also, check if any missing authorization is causing this issue. Swtich on ST01 traces for the userid and analyse.

    Regards,

    Sarbjeet Singh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Masa,

      Thanks for your response. Strangely the issue that I have described above occurs only in Google Chrome and Mozilla Firefox browsers. When tested in Internet Explorer 9 everything works perfectly - the navigation to the applications works fine.

      We have opened an incident to SAP which is currently in process. I will update the thread once we get something on the incident.

      Regards,

      Saurabh

  • Nov 09, 2015 at 10:10 AM

    Hello experts,

    We are trying to implement Simple Finance based Fiori apps. We have configured and activated these apps and are trying to access these from the launchpad. However, for many of the apps (not all apps, some of them open fine) we are seeing the below error message in the Firefox/Chrome developer console for the Fiori app Create Manual Payment:

    The user with which we try to open the Create Manual Payment app has all the required roles assigned (SAP_SFIN_TCR_T and SAP_FIN_TCR_T).

    Does anyone know if this is some known issue with SAP_UI SP14?

    Regards,

    Saurabh


    SFIN_Error.png (9.4 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Hi Karan;

      Do you see any other different error in the browser console.

      Check the network tab also and look at the last call which is made to the server.

      Check if there are any logs in the backend error logs

      Regards,

      Sarbjeet Singh