Skip to Content
avatar image
Former Member

EHP2 to EHP4 Upgrade - PREP_EXTENSION/ADDON_QCALC: BI_CONT

I am performing a sandbox upgrade with SUM (SP13). During configuration (in the PREP_EXTENSION) I encountered the following message:


"The program is unable to generate the add-on queue due to missing add-ons or Support Packages"

I have included a screenshot below. It appears that the Maintenance Optimizer did not properly calculate the correct target in the stack.xml file for BI_CONT. I used SOLMAN 7.1 (SP13) to run MOPz. My question has anyone else encountered this particular error? If yes, how did you resolve it. I have consulted the following notes:

2052771 - MSS: Additional Information – Software Update Manager 1.0 SP13

1705923 - Wrong SP Level of components contained in an upgrade export

1766326 - BI_CONT add-on error during upgrade

1678780 - Installation or upgrade BI_CONT/BI_CONT_XT 707/737/747

1943931 - Installation/Upgrade for the ABAP Add-On BI_CONT / BI_CONT_XT 757

I have also seen similar issues discussed in another forum:

Has anyone resolved this issue before? Any suggestions on how I should proceed. Right now, I'm thinking I need to go back and 1) troubleshoot my maintenance optimizer; 2) make sure the SLD and/or LMDB is correct and 3) start over from there. Any additional guidance would be greatly appreciated.

My sincere thanks in advance.

Stephen Ferracioli

BI_CONT.JPG (61.2 kB)
BI_CONT.JPG (61.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 29, 2015 at 11:28 PM

    After reading 2053094 - ERROR: Mark relevant instance to include the software component SAP NW 7.0 BI CONT ADDON 7.05 in SMSY/LMDB

    I turned OFF the SLD send in the target system. I manually assigned Business Intelligence as a Technical System to the target system in the LMDB.

    I was then able to re-run MOPz and properly add the missing BI_CONT selections to the Download basket and generate a new stack.xml file.

    Business Intelligence is missing in the Installed Software Information (ISI). So if I turn the SLD send job back on, it will overwrite. I have decided to look at the problem later. And focus on the upgrade at hand.

    The question is do I start SUM over? Or can I run SAPCAR and extract the files into the EPS/in and repeat the PREP_EXTENSION/ADDON_QCALC step? I'm going to try the SAPCAR extract and see what happens when I re-run the step.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Final update for this thread. I was able to successfully run PREP_EXTENSION/ADDON_QCALC with the correct version of BI_CONT (747 and 757) and the SUM process has now run several steps past that step. Manually updating the LMDB allowed me to re-create a correct stack.xml file. I still need to look at fixing tables SWFEATURE and SWFEATUREINC with the SUM procedure but decided to go with the workaround for now.

  • avatar image
    Former Member
    Oct 29, 2015 at 06:13 PM

    I just checked the LMDB and see that the "Product Assigned" checkbox is unchecked. Anyone know how to fix this? I have the latest (Oct-2015) CR Content imported into the SLD.


    BI_CONT_002.JPG (140.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2015 at 08:00 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Putting this "on hold" for the moment and trying a workaround by manually assigning Business Intelligence to the LMDB.