Skip to Content

WebI prompts rounding decimal values to 2 digits

Hi,

                Has anyone ever experienced this?

               When using a dimension that is a decimal with 4 digit precision (could probably be 3 and more), when using that dimension in a prompt in the Query Panel, WebI is rounding that number to 2 digits.  This can be seen by viewing the Query Panel SQL script.  When using it simply as a constant, it does not get truncated.  The 4 decimals are really important as measures associated to these points are used thereafter to retrieve all the records within an interval based on that dimension.

                Ex:  Between 15.5555 and 16.5555 is not the same as between 15.56 and 16.56...

                The values are set as dimensions even if the values are decimals as they reflect coordinates.

Database field is set to Numeric with 4 precision.

Datafoundation layer is set to Numeric with 4 precision.

Business Layer is set to Numeric.

When displaying values at each step, values are correct.

Thanks,

Windows Server and Windows workstation

BI LaunchPad WebI HTML/Java

BI 4.1 SP3

UNX on Netezza database.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jun 16, 2016 at 08:46 AM

    Hi,

    Please use below syntax:

    @Prompt("Enter XX",'A',,,)

    I have tried this and worked for me.

    Thanks,

    Manveer Nakoti

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you but I was referring more the the filter as a prompt in the WebI panel and not the universe prompt. Dragging that dimension object in the filter and changing the filter to a prompt causes rounding issues not desired from 4 decimals to 2 decimals on the entered values from user. When using the same object to filter but setting it as a constant and entering 4 decimal number, that seems to not have rounding issues.

  • Jun 16, 2016 at 04:20 PM

    Which locale are you using? Try changing at the Locale level

    Hopefully this would help.

    In Control Panel -> Regional Setting -> Additional Setting -> Increase no of digits after decimal to 4

    You might need to restart the BO services to take the changes to effect in the report.


    Sample.jpg (74.0 kB)
    Add comment
    10|10000 characters needed characters exceeded