Skip to Content
avatar image
Former Member

Outbound Interface: Proxy to SOAP Interface

Dear PI Experts,

My scenario is : SAP(Proxy)----->PI------>SOAP external WebserviceSystem.(external to my client network).

In PI  Dev, QA systems interface is working fine.

In Prod system while sending the data to third-party web service system in PI message status showing in success status in RWB but third party system did not receive the data.

Target system is external to my client.

I am using same process in D,Q,P .

SOAP Target URL is different for D,Q and P.

same proxy server using in SOAP Adapter because of target system is external to my client network.

Please can you suggest me on this issue.

Thanks,

Aadi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 29, 2015 at 10:31 AM

    Hi,

    Is your scenario async?, i suppose that. I think you should go to the communication channel monitoring and to check if there is any exception in the audit log.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 29, 2015 at 11:13 AM

    Hello Aadi,

    Check the CC monitoring as suggested by Inaki.

    Ensure first the URL is accessible and you have permission to post data by chaning the URL in the quality or using Soap UI.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2015 at 06:40 PM

    Hi Aadi,

    Can you please try sending one message to Prod. system from your SOAP UI tool and ask your target system to confirm if they have received the same? If the issue persists, its confirmed that its issue on the target system side.

    Otherwise,as already suggested earlier in this blog trail please check in RWB channel monitoring and message monitoring for any error clues on the PI side.

    Thanks,

    Anirban.

    Add comment
    10|10000 characters needed characters exceeded