Skip to Content
avatar image
Former Member

Can not use existing request after change of original system in Package

Dear Experts,

i am facing a critical issue.

The story begins with

loong long ago, .... a program was assigned to a wrong task, I just need to change it to another task.

according to the info from SCN, i delete the object in SE10 from the task, and go back to the object and try to save / activate and use another one.

At that moment, after changing e.g. a report I can not use the existing transport request ( task ) , and get the message : You can not use the request xxxx.

before I deleted the object in Se10 , we changed the orginal system in SE03 for this package (to which the program is assigned).and set type from repair to dev.

It seems we also need to change the transport layer of this package to the system default layer, Is it true that I should use the layer I found in in STMS ( transport route ) ?

And in SE03 , as i tried to change the layer of this package. I was asked again of creating a new transport request, because there is no request to choose.

Thus i would like to ask, what I should do to make this transport layer correct, and my target is , that changes in programm can be assigned to the correct transport request / task.

Thanks a lot.

PS: If any pics or screenshots needed, just post, I am waiting online.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Oct 29, 2015 at 10:31 AM

    Hello Recke,

    Look at things this way.

    Your program is assigned to a Package (Dev Class) and this Package is linked with a Transport Layer.

    If you post the information of your programs Package and also your current transport route config it will help others to help you.

    Is there a particular reason you must use an existing request ? I fully understand that with some customer a master request is created and tasks are assigned to the master request in order to bundle transports. If here isn't a specific reason, why don't you just create a new transport request when you modify the program ?

    KR,

    Amerjit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      sorry for the later reply,

      the problem is solved, the solution is :

      we can not change the original system first, but we need to change the transport layer first ( with creation of a new transport) , then change the original system, then everything is correct.

      actually what we did was , set the original system back and then change the layer, then change the system to the correct system.

      thanks for the tipps provided.

      regards