Skip to Content

SAP HAT Installation Issue

Hi Experts,

I am following OpenSAP installation guide for installing HAT.

I downloaded the HAT, unzipped and ran setup.cmd

I get below error.

As I understand from the error thrown, it is looking at a wrong place to find install_os.js so not able to find.

Any help is appreciated.

Thanks

Krishna

Installation.png (38.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 30, 2015 at 05:37 PM

    This is resolved now. Problem was that Node runtime was looking at wrong place for all relative URLs. This is why it could not find install_os.js.

    I had used a registry key to set a default directory path for Command line tool (CMD). The path set there was used by Node runtime for all relative paths within the node application. I deleted this registry entry and it all worked.

    Thanks Midhun and Jitendra.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 29, 2015 at 08:14 AM

    I can see that you have node js version as 0.12.0 but as i know for latest HAT 1.9.4, you should have 0.10.40

    Once you have it, please try reinstalling HAT.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 29, 2015 at 01:22 PM

    Hi Krishna,

    Please follow the suggestions provided here: https://open.sap.com/courses/mobile2/question/12f1f5b3-7c70-4654-8ff0-09e37ac4a04e

    Also note that for HAT 1.9.4 you need smp sdk sp09 pl04 or higher, node 0.12.7 and cordova 5.2.0

    Regards, Midhun

    SAP Technology RIG

    Add comment
    10|10000 characters needed characters exceeded