Skip to Content

Issue in Reading Java System Property from EJB

Hello All,

I have a requirement to create a property in EJB DC which is configurable through NWA.

For this, I have created an EJB DC & EAR DC.

In the META-INF folder of EAR DC, I have created “sap.application.global.properties” file.


In file, I have created the required property and deployed the application.


In NWA, these properties are getting displayed/modifiable.


In session bean of EJB DC I am wrote below code to read the required property: -



But, surprisingly, the variable “appProps” (marked in yellow) is getting returned as null, due to which null pointer exception occurs &  I’m not able to fetch the required property.


I have also tried the approach of reading props like below, but still no luck.


http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/10337a43-f09a-2d10-48ac-d7ea27d232bf?QuickLink=index&overridelayout=true&48842368271601

Any ideas on what is missing here?

Thanks & Regards,

Amey

Untitled.jpg (69.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 29, 2015 at 04:44 PM

    Hi Amey,

    Try this example:Way to Read SAP.APPLICATION.GLOBAL.PROPERTIES File via Java code

    Check that you implemented all required correctly.

    Regards,

    Roman.

    Add comment
    10|10000 characters needed characters exceeded