Skip to Content

No System Landscape Directory registered

Hi All,

I am facing with an issue for which there were couple of thread with a note, but for me it's still open.

I had built a PI 7.3sp4 dual stack system using a System Copy from another system. All post steps have been completed. But when I move to the RWB components I get the below error.

********************* No System Landscape Directory registered




at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(

at java.lang.reflect.Method.invoke(





I have checked and worked as per the notes but didn't help, might be i am missing something more.

1590607 - PI: 'No System Landscape Directory registered' error in the Runtime Workbench

1358958 - PI CTC: Error im step "Synchronize the SLDAccessor"

764176 - Manual correction of XI content in SLD

1117249 - Incomplete Registration of PI components in SLD

From the Integration Builder, working with BS, we get the error.

"InternalEOAService BusinessSystemAccessor failed"

>>>> One key think which I don't see is in the SLD >> Technical System Type >> Process Integration >> I don't see the Domain for the Integration Server. I did remove the entries as per one of the note above and restarted, but it hasn't helped. I see only Integration Server ABAP registered but no Domain.

I am still stuck up. Can you help with this if you have already faced it.

Thanks & Best Regards,


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 28, 2015 at 10:23 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ramkumar,

      Thanks for reply. I tried this one. The initial step, where I had to remove the entries and restart, I don't see things registered there. As per this doc, they will come by themselves with restart.