Skip to Content

EHP upgrade service credential error Action 'install' for DCOM service failed

Dear Experts,

EHP upgrade through SUM tool has run into "Action 'install' for DCOM service failed" although the password provided for <SID>adm to SUM in beginning phases is correct.



----------------Phase Log ------------------------

1 ETQ201 Entering upgrade-phase "PREP_INSTALL/SHDINST_OS" ("20151028113621")

2 ETQ367 Connect variables are set for standard instance access

4 ETQ399 System-nr = '10', GwService = 'sapgw10' Client = '000'

4 ETQ399 Environment variables:

4 ETQ399   dbs_ora_schema=SAPSR3

1 ETQ200 Executing actual phase 'PREP_INSTALL/SHDINST_OS'.

4 ETQ399 Adding key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Application\SAPDEV_11

4 ETQ399 Setting value:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Application\SAPDEV_11\ImagePath

3 ETQ120 20151028113621: PID 13172 execute 'G:\EHP5_EHP7\SUM\abap\exe\sapstartsrv.exe -r -q -p G:\EHP5_EHP7\SUM\abap\system\DEV\SYS\profile\DEV_DVEBMGS11_***DEV -s DEV -n 11 -U .\SAPServiceDEV -P <HIDDEN> -e ***DEV\devadm', output written to 'G:\EHP5_EHP7\SUM\abap\log\SAPup.ECO'.

3 ETQ123 20151028113626: PID 13172 exited with status -1 (time 0.000 real)

4EETQ399 An error occurred during the installation of the

4EETQ399 SAP service SAPDEV_11:

4EETQ399 Possibly the password for user .\SAPServiceDEV entered in phase

4EETQ399 INITPUT was wrong. You can reset it by calling 'SAPup set stdpar'.

4EETQ399 Try to execute SAPSTARTSRV.EXE manually using the following syntax:

4EETQ399 G:\EHP5_EHP7\SUM\abap\exe\sapstartsrv.exe -r

4EETQ399 -p G:\EHP5_EHP7\SUM\abap\system\DEV\SYS\profile\DEV_DVEBMGS11_***DEV -s DEV -n 11

4EETQ399 -U .\SAPServiceDEV -P <PASSWORD> -e ***DEV\devadm

4EETQ399 and check if the service SAPDEV_11 can be stopped and restarted.

1EETQ399 Last error code set is: Action 'install' for DCOM service failed, see phase log for details: Cannot create a file when that file already exists.

1EETQ204 Upgrade phase "SHDINST_OS" aborted with severe errors ("20151028113626")

------------------------------------------------------------------------------------------------------------------------------

I tried resetting password by calling SAPup set stdpar but it says SERVICE MARKED FOR DELETE.

Kindly help me.

Thanks in advance,

Regards,

Domnic

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 28, 2015 at 02:59 PM

    I executed the steps as per Snote - 1563660 - sapcontrol, user authorization issues (SUM)


    for all the steps of StopService, StartService and restart i get same error  as in below screen.

    Kind Regards,

    Domnic.



    Service-Reset.jpg (28.4 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Domnic,

      Can you please check the SAP note: 2179539 - SHDINST_OS: Action 'install' for DCOM service failed, to resolve the issue.

      Regards,

      Maha