Skip to Content
avatar image
Former Member

Dump RAISE_EXCEPTION happens while frontend printing

Dear experts,

I am facing some issues regarding to RAISE_EXCEPTION runtime error. At the beginning I thought it was an issue with the SAP GUI version, I have updated to the last version (740 PL4), the issue was not solved, then I have updated the system to the last kernel patch (742 PL222), the same result, it didn't work.

After trying to reproduce the error with the users we have found that the DUMP is triggered when the user prints (users don't print a large amount of pages, with two simple pages fails), 2 of out of ten prints fail. The strange is that if the user sends the request again when fail, this one  is completed without problem (The same procedure, the same print).

In that sense I started to realize that maybe the issue is with the network. In the Company we work with Wireless and wired networks and in both cases fail. In general terms the network works fine, however I am looking at "WSAECONNRESET: Connection reset by peer" errors in the logs.

The closest to the error  note  is 2030139, but It didn’t solve my issue.

Error analysis

    A RAISE statement in program "SAPLOLEA" has raised exception condition


    Since the exception was not caught by a program higher up in the call

    hierarchy, processing was terminated.

    Short text for exception condition:

    You can find detailed documentation about the exception condition in

    transaction SE37 (Function Library). You can find the name of the

    function module called from the display of active calls.

    Last error logged in SAP kernel

Component............ NI (network interface)

    Location.......... SAP-Gateway on host / sapgw00

Version.............. 40

    Error code............ -6

    Error text............ connection to partner '' broken

    Description............ NiIRead: P=; L=

    System call.......... recv

Module.............. D:/depot/bas/742_REL/src/base/ni/nixxi.cpp

Line................ 5386

    The error reported by the operating system is: Error number..... 10054

    Error text....... "WSAECONNRESET: Connection reset by peer"

DEV_RD log file

***LOG Q0R=> GwReadFromRemGw, GwRead ( GwRead-006) [gwdp.c       4746]

Tue Oct 27 11:20:19 2015

***LOG Q0I=> NiIRead: P=; L= recv (10054: WSAECONNRESET: Connection reset by peer) [D:/depot/bas/742_REL/src/base/ni/nixxi.cpp 5386]

*** ERROR => NiIRead: SiRecv failed for hdl 125/sock 2748

(SI_ECONN_BROKEN/10054; I4; ST; P=; L= [nixxi.cpp    5386]



*  LOCATION    SAP-Gateway on host / sapgw00

*  ERROR       read from SAP gateway failed


*  TIME        Tue Oct 27 11:20:19 2015

*  RELEASE     742

*  COMPONENT   SAP-Gateway

*  VERSION     2

*  RC          239

*  MODULE      D:/depot/bas/742_REL/src/krn/si/gw/gwdp.c

*  LINE        4716

*  DETAIL      connection to gateway on host / sapdp00 broken

*  COUNTER     9376



***LOG Q0R=> GwReadFromRemGw, GwRead ( GwRead-006) [gwdp.c       4746]

Tue Oct 27 11:22:08 2015

NiHLGetHostName: to get failed in 4514ms (tl=2000ms; UC)

Tue Oct 27 11:23:48 2015

NiHLGetHostName: to get failed in 4618ms (tl=2000ms; UC)

Tue Oct 27 11:33:22 2015

NiHLGetHostName: to get failed in 4521ms (tl=2000ms; UC)

Tue Oct 27 11:35:19 2015

*** ERROR => GwHdlRqFromSapWp: no comm_adm entry found [gwdp.c       1267]

*** ERROR => (rq/idx/convid/session=9/74/95800100/NO_SESSION_INFO) [gwdp.c       1273]

*** ERROR => GwRqServiceQueue: GwHdlRqFromSapWp failed, rc=-1 [gwdp.c       5976]

Tue Oct 27 11:44:20 2015

NiHLGetHostName: to get failed in 4513ms (tl=2000ms; UC)

System log

A  ** RABAX: level LEV_RX_APC_ERROR entered.

A  ** RABAX: level LEV_RX_APC_ERROR completed.

A  ** RABAX: level LEV_RX_DATASET_CLOSE entered.

A  ** RABAX: level LEV_RX_DATASET_CLOSE completed.

A  ** RABAX: level LEV_RX_ERROR_SAVE entered.

A  ** RABAX: level LEV_RX_ERROR_SAVE completed.

A  ** RABAX: level LEV_RX_ERROR_TPDA entered.

A  ** RABAX: level LEV_RX_ERROR_TPDA completed.

A  ** RABAX: level LEV_RX_PXA_RELEASE_RUDI entered.

A  ** RABAX: level LEV_RX_PXA_RELEASE_RUDI completed.


A  ** RABAX: level LEV_RX_LIVE_CACHE_CLEANUP completed.

A  ** RABAX: level LEV_RX_END entered.

A  ** RABAX: level LEV_RX_END completed.


M  *** ERROR => caught error :  [dynpabsv.c   581]

S  *** ERROR => internal mode aborted [rsporperf.c  78]

S  *** ERROR => NEW_FRONTEND_PRINT(RSPOLPRF) aborted [rsporperf.c  154]

S  *** ERROR => calling frontend form NEW_FRONTEND_PRINT failed (rc = 99) [rspofront.c  987]

In that sense, What do you recommend me to do? I am frozen here.



Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 27, 2015 at 06:45 PM
    Add comment
    10|10000 characters needed characters exceeded