Skip to Content
avatar image
Former Member

sia server not starting after migration cms db

Hi experts:

We have sap bo xi sp5 in aix with a cms db of db2 8.2 and migrate this db to db2 9.5. We changed all the AIX variables (LIBPATH, PATH, DB2DIR INSTHOME and DB2INSTANCE) and perform a test with db2 command tool where we can connect successfuly to new database.But when i Try to start the servers (running the startservers) the system keeps down.

If i run the cmsdbsetup.sh script I get the following message:

err: ERROR Failed to get cluster name. (STU00165) err: Error description: The index was not created because an index "BO31QADM.SI_INSTANCE_OBJ_I6" with a matching definition already exists. SQLSTATE=01550

In fact this index exists in the database but sounds strange that it's being created again.

Our environment: SAP BO XI 3.1 SP5 on AIX 6.1.9.5

CMS and audit DB: DB2 LUW 9.5

Any ideia?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 27, 2015 at 01:28 PM

    Hi,

    Adding one more important KBA -

    1667586 - Backup and restore of filestore and cms database of a BusinessObjects Enterprise XI 3.x system on Unix

    I hope this helps.

     

    Regards,

    Rukaiya

    Add comment
    10|10000 characters needed characters exceeded

    • Antonio,

           The first thing you need to is split the Application Server and Database Server, you NEVER install the Application and Database on the same server.  You best option is install NEW DB2 Database server and copy the databases to new server.   For CMS migration you should use the CMS datasource copy tool.

      Regards,

      Ajay

  • Oct 27, 2015 at 01:02 PM

    Antonio,

          Since the DB driver has changed from DB2 8.2 to 9.5, you will need to reset the CMS Database connection.   Open the SIA, remap to new DB2 9.5 data-source and re-initialize the SIA, see step-by-step instruction

    How to Restore BI4 from FRS & CMS Backup

    Regards,

    Ajay

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 27, 2015 at 01:25 PM
    Add comment
    10|10000 characters needed characters exceeded