Skip to Content

BPC 10.1 UJO_READ_EXCEPTION_000

Hi all,

After chaging an ACCOUNT from LEQ to INC, we are facing the following reporting issue related to ACCOUNT hierarchy:

We have changed member properties, the hierarchy and processed the dimension successfully several times,  but the reporting issue has not been solved. We can only create reports using account basemembers.

We have run UJA_DATA_CHECKER program and shows no errors.

We have also applied SAP note 1673094.

Our system: BW    Release 740 SP-level  0012

                   BPC: Release  810 SP-level  0007

Any ideas?

Thanks,

Carlos

UJ0_read_error.JPG (73.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 05, 2015 at 11:06 AM

    Hello Carlos,

    I have solved the ACCOUNT hierarchy problem applying the following note:

    2190242 - UNCAUGHT_EXCEPTION related to hierarchy invalidation in CL_RSDRH_HIER_CACHE

    Basically, it is a import to SP 13 for SAP BW 7.40.

    After the implementation, I no longer have issues with the ACCOUNT hierarchy.

    It seems that it was a problem of synchronization between BPC side and BW side. The ACCOUNT hierarchy in BW side remained always in M version (Modified), instead A version (Active). We had differents hierarchies structures in both sides (a lack of synchronization). Now, it is synchronised, with the hierarchy in A version.

    The problem was only in ACCOUNT dimension, no more.

    Hope that helps,

    Regards,

    Manu

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 27, 2015 at 11:20 AM

    Hi Carlos,

    Can you show the account hierarchy? And the changed account in it?

    Vadim

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2015 at 04:13 PM

    Hello Carlos, Vadim,

    I have got the same issue that you comment. I am in BPC 10.1 and here are the details of my error:

    - Refreshing a existing report, I had exactly the same error that appears in the screenshot above. With the dimension ACCOUNT, too.

    Code: UJO_READ_EXCEPTION_000

    Description: MDX statement error: dimension [*technical name dimension* PARENTH1] unknown.

    - Until last week, I have never had this error, wich appeared after we upgraded some system components.

    Old components system:

    Current components (after upgrading):

    As you can see, SAP_BW Release 740 was upgraded to SP 12 and CPMBPC Release 810 was upgrade to SP 7.

    It seems that the error has come from this upgrades.

    - I checked UJA_DATA_CHECKER. No errors.

    - Following the note 1673094, I also tried to add "MDX_USE_CLASSIC_PARSER" with value "X" in RSADMIN table. But does not work.

    - How I have solved this temporarily? Creating a new hierarchy (like PARENTH2) in ACCOUNT dimension. Copy PARENTH1 to PARENTH 2. Delete PARENTH1 and use the new hierarchy. This is a good provisional solution.

    Hope that this information helps.

    Kind regards,

    Manu


    old.jpg (29.9 kB)
    new.png (26.8 kB)
    Add comment
    10|10000 characters needed characters exceeded