Skip to Content

ABAP 7.40 SP5: Filling itab cell

Hi,

why the following coding does not work:

DATA:

  "! result of ship-to-party determination

  ship_to_party type kunnr,

  "! partners table

   "! one entry has an empty partn_numb

   partners type standard table of bapiparnr.

* ship-to-party determination

* ....

* partner-table is not filled completely,

* because one partner has no number,

* for this reason, we had to determine this number

* and now we want to write this number into the table

partner[ part_numb = space ]-partn_numb = ship_to_party.

* result: no sy-subrc, no exception, cell not filled!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 27, 2015 at 10:00 AM

    Hello Ralf,

    I tried on  below installation and it worked for me.

    SAP_BASIS7400004SAPKB74004SAP Basis Component

    Sample Code -

    REPORT  ZA_1.

    DATA:

       ship_to_party type kunnr value 10,

       ls_partner   type ZCDP_QUESTION,

       partner type standard table of ZCDP_QUESTION,

       partners type standard table of zcdp_Assessment.

    insert ls_partner into partner INDEX 1.

    partner[ question_id = space ]-COMPLEXITY_ID = ship_to_party.

    BREAK-POINT.


    * At this stage the value gets copied to the 'Complexity_ID' column in the same row of table.

    * Please note that i have reused some structures and table types of my own here.


    BR.


    Add comment
    10|10000 characters needed characters exceeded

  • Oct 27, 2015 at 06:58 PM

    Hi Ralf,

    working here too.

    Btw. the new table and iteration expressions never set sy-subrc or other system variables.

    In your example if the line is not present in the internal table the exception CX_SY_ITAB_LINE_NOT_FOUND if fired by the runtime system and leads, if not catched, to a shortdump.

    Maybe ship_to_party is empty?

    Regards Christian

    Add comment
    10|10000 characters needed characters exceeded