Skip to Content
avatar image
Former Member

Different Links in Web service - how to deploy?

Hello All,

I hope you can help me.

In our Landscape we have more than 2 Tenants which are connected to different Systems.

So I do the developing in the Development Tenant. The Testing is done in the Test Tenant and then we have the Productive Tenant.

My Problem is, that we have implemented a Web Service in a kind of big Solution, where i have to do some changes (due to corrections) sometimes.

We consume this Web Service.

When now deploy to the Test Tenant, I of course consume the Web Service which is provided by the Test System (also SAP System)

This WSDL contains Link (like) "http://TestSystem.Link123[...]". This is the Link for the Test System Web Service.

Now we want to go Productive. Of Course we must now use the Productive Web Service with the link in WSDL (like) "http://ProductiveSystem.Link123[...]".

This is different.

Is there a good way how to deploy this?

I mean, I now have to change the WSDL in the development Tenant, download and assemble and then upload it to the Productive System,

But what do I do, when there is a change in the development?

Then I have to do the changes and deploy first to the Test Tenant, but in the Solution there is the wrong WSDL in the Web Service, so this won't work in Test Tenant.

Hope you can understand what I mean and help me in some way.😕

Thanks and best Regards,

Astrid

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Oct 27, 2015 at 02:10 PM

    Hi Astrid,

    From my experience, the URL in the WSDL does not matter.

    In order to have a webservice work, you need the parts implemented using the PDI as well as two things configured in the tenant.

    In the tenant you have to create a communication arrangement mapped to a communication system.

    The communication system specifies the destination system where the webservice connects to.

    So as long as you have a different communication system defined in the test and the productive tenant, your scenario should work.

    best regards,

    Ludger Bünger

    --

    Custom Development with all4cloud.de

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Ludger,

      I checked you proposal and just add the correct Link in the Communication Scenario/Arrangement.

      The Link in the WSDL seems not important.

      Thanks and best Regards,

      Astrid