Skip to Content
avatar image
Former Member

Loading Korea Characters from Flat file into HANA through DS Job

Hi All,

I have Flat file as Input. This Flat File Contains 10 Columns with Pipe Delimiter.

Out of 10 Columns, 3 columns are Korean Language Characters. While loading data from Flat file to HANA Table through DS Job, Instead of Korean characters, ##### are being stored in Table.

Could you please help me how to load Korean characters properly?.

Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 27, 2015 at 06:06 AM

    You've got to make sure that code pages for source file, DS and target database all support Korean characters.

    For DS and HANA, that shouldn't be a problem, they do by default. But check that the code page in the flat file properties is set to utf-8, not default.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Data from Flat file to first Template table loaded properly Including 3 Korean Columns.

      After transforming logic on English Columns, 3 Korean Columns are being populated as ####.

      Regards.

  • avatar image
    Former Member
    Oct 27, 2015 at 12:02 PM

    Hi Chaitanya,

    Please convert the code page for source flat file as UTF8 & also in target file please set the below option to YES...

    (USE NVARCHAR for VARCHAR columns in supported databases to YES).

    Regards

    Krishna Mohan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 27, 2015 at 03:57 PM

    The Data Store which stores the Template Tables has not been configured for UTF-8.

    I changed to UTF-8 and now data is loading good.

    Thank You all for your Inputs.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded