Skip to Content

A4H: WSAEWOULDBLOCK: Resource temporarily unavailable

I have been trying to access A4H system (SAP NetWeaver Application Server ABAP & SAP Business Warehouse 7.4 SP8 on SAP HANA 1.0 SP8 [developer edition]) for many times. Every time I am able to logon to Windows server - However, connection to SAP A4H instance via SAP GUI on the remote machine gives following error:

I have already tried suspending and Activating the instance. Also, tried terminating and recreating the instance.

I have been using A4H for many months without any issue. Facing this issue since past 2 weeks.

I am using AWS (us-east-1).

Not sure what's going on. Any quick help, suggestions - will be highly appreciated.


I am able to login to SAP server via PUTTY with 'root' userid. Didn't see anything unusual. GetProcessList says all GREEN.

Was able to execute 'startsap r3' successfully.

So it looks like SAP instance is running fine.

Something should be wrong with the connection between front end and backend via SAPGUI.

I am not able to ping the ip address of the SAP server external IP address - which is weird.

Assuming its to be windows firewall issue- I set it to OFF. Still no success with the connection.

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Posted on Oct 27, 2015 at 08:33 AM

    Hi Rahul,

    The ping service is disabled by default in AWS. What you could do instead is to telnet the SSH port and the SAP Dispatcher port via the external IP.

    telnet <external IP> 22

    telnet <external IP> 3200

    Please also check in the instance details that there is an access point for port 3200.

    Best regards,


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Rahul,

      Most probably the root cause is an unexpected error during the initial startup of your instance. We can investigate the problem if you would be willing to collect the logs from you system and send them to There are few log files generated during the instance initialization. They are located in /var/log/appliance*.log on the Linux box.

      It would be a time consuming task to fix this particular instance if I am right about the error, so I’d recommend to terminate the instance and create a new one.

      Also please note that a new version of the same solution will be released soon, so you might prefer to wait for it.

      Best regards,