Skip to Content
avatar image
Former Member

Issue with WEBI reports based on Multi Source Universe

Hi Folks,


We are facing an issue with the WEBI report based on the multi-sourced

universe.


Environment - BO 4.1 SP5

Data source - 2 Oracle 11.2 sources


When we select the prompt values and refresh the report it throws the

error as

Database error: [Data Federator Driver]

Cannot Reach Server. Reason: attempt to establish connection failed:

java.net.ConnectException: Connection refused: connect. (IES10901)

(Error: INF)


rgds,

Prakash S

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 27, 2015 at 11:44 AM

    Hi Sivaraj,

    Check servers once in CMC

    Thanks

    Riaz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I purely by chance noticed that what seems to be happening is the Data Federation service is crashing and restarting.

      I found this because I worked out if I have the crash and log out of Webi and back in the report seems to work for a few refreshes before crashing.

      Once crashed 5 times though I was getting some error about not be authorized to return data from the universe.

      I logged into the CMC and by chance notice that the DF service had stopped - with the explanation being it had crashed 5 times within and hour.

      I restarted it, switched to Webi to run the report and when it crashed I happened to flick to CMC and saw the service was initializing.

      I've tried stripping back my report query by query to see if it's a specific data provider with no luck, even went through the universe and gave unique names to each object as I think I saw that suggested somewhere - still no luck.

      Because of the way our environment is set up we have to have 3 sets of connections and 3 .DFX and repoint the universe to the appropriate DFX before promotion.

      Because I've been playing around with all of the various components trying to fix this issue, our DEV Webi environment is currently using the PROD connections ad universe.

      I happened to notice last night that it doesn't seem to crash in DEV !!! i.e. I ran the report about 20 times with various prompt values and no issue.

      So, now I have to work out what the difference is between the two environments - needle in a haystack - could be any setting any where or something in the promotion - meanwhile my boss is suggesting we 'give up' on multi source universe and try and rework the report using two single source universes.

  • avatar image
    Former Member
    Oct 29, 2015 at 05:01 AM

    Same issue, randomly, using SQL Server back end.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2015 at 04:54 AM

    Hi,

    Refer SAP Note: 1901933

    Cause

    The connection to the host is not available. Possible causes are:

    • Incorrect host or port entry in the ODBC.ini
    • Firewall blocking host/port destination
    • Client is unable to resolve hostname of the database host

    Resolution

    • Changes need to be made to the areas defined by the causes above. The ping command can be used to determine if a host can be reached by hostname or IP.
    • If unable to connect via host name or IP then the issue is likely with a firewall.
    • If unable to connect by host name but can connect by IP the issue is with name resolution.
    • If both can be pinged then the issue is likely an incorrect entry or syntax in the ODBC.ini
    Add comment
    10|10000 characters needed characters exceeded

    • I can't seem to find the original one(been a long time); and possibly Microsoft has released a patch to correct.  Here looks to be similar to what i found.. https://support.microsoft.com/en-us/kb/2881661  .  We  could see the following   in the Stack dump.

      --------------  N a t i v e   C r a s h i n f o  ---------------

      Stack:

          SP                 PC                 RetPC              Symbol

      0: 0x000000002a9be110 0x0000000053fb1391 0x0000000053fd4f37 dbd_wsqloledb::????