Skip to Content
avatar image
Former Member

KF value hidden when Unit is in Row

Hi Guys,

I am facing an issue in a BEx report as it is not displaying key figure values while executing it. Let me explain in brief.

When I keep Base Unit of Measure (0BASE_UOM) in Rows of the Query, then I am unable to see the key figure values as it shows blank cells in columns but when I remove the Base Unit from the rows while executing the report in AFO, then I can see the correct Key figure values.

Does anybody have any idea how can I see the KF values even if I keep Base Unit in rows?


P.S. : The Keyfigures contain Pricing Data.

Any ideas or helpful links are greatly appreciated. Thanks in advance. Let me know if anyone wants to have more details on this.

Regards,

Sambit

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 26, 2015 at 03:24 PM

    Hi Sambit

    We have such queries in our project and it works perfect without any issues.

    Does your keyfigure's UOM measure is BUOM?

    If you display the data in your infocube, does the keyfigure shows against BUOM?

    Once we have some problem with displaying BUOM, but I forgot the exact reason. The solution which resolved the issue is we have BUOM as an attribute of 0MATERIAL info-object. So we just added that and it worked. You could try that as well.

    Regards

    Karthik

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kartik,

      Yes, that is what I also tried with in the query yesterday. 0BASE_UOM is removed from rows as an independent characteristic and is added only as a display attribute of 0MATERIAL which resolved the issue and User is also fine with that.

      Regards,

      Sambit