Skip to Content
avatar image
Former Member

'Tcode: /n/sapapo/sdp94 ' Error Dump. : ABAP program "/SAPAPO/SAPLMSDP_PI" had to be terminated

I Attached and uploaded Screen Shots' of Error.. Plz help.....Experts.

Tcode: /n/sapapo/sdp94 '    whenever Im accessing this Tcode for (Interactive Demand Planning). Im getting Dump.

1)  Previously for First time I typed Tcode: /n/sapapo/sdp94    it worked-----> it asked me Planning Area and  Time Series.  "I think i gave Wrong Parameters"

      So System suggested Planning Area : 9ADKSISN (something like this) and Time Series(i created for other Planning Area).  Once I saved This.

2)  Now WhenEver I Type Tcode: /n/sapapo/sdp94 '  .. it shows Dump Error :

Runtime Errors  

OBJECTS_OBJREF_NOT_ASSIGNED

Except.           CX_SY_REF_IS_INITIAL Date and Time     26.10.2015 18:46:03

Short text

Access via 'NULL' object reference not possible.

What happened?

Error in the ABAP Application Program

The current ABAP program "/SAPAPO/SAPLMSDP_PI" had to be terminated because it has come across a statement that unfortunately cannot be executed.

What can you do?

Note down which actions and inputs caused the error.

To process the problem further, contact you SAP system administrator.

Using Transaction ST22 for ABAP Dump Analysis, you can look at and manage termination messages, and you can also

keep them for a long time.

Error analysis

    An exception occurred that is explained in detail below.

    The exception, which is assigned to class 'CX_SY_REF_IS_INITIAL', was not

    caught in

    procedure "/SAPAPO/PI_SDP_CREATE" "(FUNCTION)", nor was it propagated by a

    RAISING clause.

    Since the caller of the procedure could not have anticipated that the

    exception would occur, the current program is terminated.

    The reason for the exception is:

    You attempted to use a 'NULL' object reference (points to 'nothing')

    access a component (variable: "CHILD_CONTROL_1-APOGRID").

    An object reference must point to an object (an instance of a class)

    before it can be used to access components.

    Either the reference was never set or it was set to 'NULL' using the

    CLEAR statement.

Error2.jpg (151.2 kB)
Error1.jpg (130.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 26, 2015 at 01:42 PM

    Hi David,

    Go to /SAPAPO/SDPPLBK - Assign User to Planning Book and assign right planning book and data view to your user ID and save.

    Try thereafter and let us know, do you still get the same error.

    Regards

    Rahul

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      No  Rahul same Issue.............Repeating..............

      Actually I assign Wrong Planning Area....at " n/sapapo/sdp94" .

      May b I used  NULL' object reference

  • avatar image
    Former Member
    Oct 26, 2015 at 03:11 PM

    Is there any way to Reset "Interactive Demand Planning " Data. ie /SAPAPO/SDP94.

    I mean Whatever i entered inside Tcode /SAPAPO/SDP94.  ?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2015 at 03:25 PM

    Finally after Lot of Research ....Done by Me.....I got Success in Solving this Problem....

    What i did was ...Whatever 'Planning Area'  I accidently assigned in Tcode :"/SAPAPO/SDP94"

    ie, "Interactive Demand Planning"


    I went to DP/SNP Administration : /SAPAPO/msdp_admin  and deleted Time Series for Activated Planning Area...ie which was Assigned by me Accidently in Interractive Demand Planning Tcode.


    Finally my Problem got Solved.


    Thanks.

    Add comment
    10|10000 characters needed characters exceeded