Skip to Content

SAP IQ Cockpit - Chrome & Firefox error "ERR_SSL_WEAK_SERVER_EPHEMERAL_DH_KEY"

Hi all,

      installing last browsers upgrades I was unable to access the SAP IQ cockpit (version IQ 16.08 PL35).

The problem is showed both using Chrome (version 46.0.2490.80 m) and Firefox (versione 41.0.2) while all continue working in MsExplorer.

Both Chrome and Firefox report the following error: "ERR_SSL_WEAK_SERVER_EPHEMERAL_DH_KEY".

I known that some workaround (browser side) are available like described here: http://service.sap.com/sap/support/notes/2192621 for another SAP product.

However my idea is to fix, if it is possible, the issue server side forcing cockpit tu use a stronger cipher algorithm.

I found the solution for other SAP products (Weak ephemeral Diffie-Hellman public key) , but using the provided informations I am not able to apply that solution also to the cockpit case.

Do you have a specific step-by-step fix procedure for IQ Cockpit issue?

Best regards,
Stefano

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 26, 2015 at 02:50 PM

    Please try and see if
    http://service.sap.com/sap/support/notes/2190942 helps.

    Regards
    Harpreet

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 08, 2015 at 09:48 AM

    This is also another alternative. Start up Chrome with the following parameter:

    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --cipher-suite-blacklist=0x0088,0x0087,0x0039,0x0038,0x0044,0x0045,0x0066,0x0032,0x0033,0x0016,0x0013

    Add comment
    10|10000 characters needed characters exceeded