Skip to Content

Language drop down not showing the marathi language in masthead.

Hi All,

we are implementing the portal 7.4 ,we are trying to implementing the language switching option(English/marathi) for user in masthead,where Marathi is the Indian language , for that we have taken standard component from portal ( creted masthead iview,in iview properties we enable the language drop down in that showing the all the available locales in portal but my target language marathi is not showing.

For marathi language we added the(mr- for marathi) locales in and ume.admin.wd.locales.

In UME We are getting the marathi language

But in masthead not showing thw marathi language.

Please kindly help me.



Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 25, 2015 at 06:51 AM

    Hi Apps,

    The blog that explains how the portal determines the language:

    Setting the iView Language in the Portal

    In the event that the required locale is not on the Java Runtime Environment-supported list of locales, to add additional locales, see Start iViews with a Dynamically Computed Language

    or SAPnote 1013521 - Configuration of supported languages within the portal if the language

    is on the Runtime Environment-supported list of locales.

    Best regards,


    Add comment
    10|10000 characters needed characters exceeded

    • Dear Etay,

      Thanks for your inputs and reply i tired above steps but nothing happen,

      We tried another way to switch the user for English and Marathi languages portal 7.4 ,through language parameter through URL.

      If I use the /irj/portal/anonymous access the user give the language settings of browser.

      I've created various anonymous users with corresponding languages: Guest_EN, Guest_MR, etc.

      If I use /irj/portal/anonymous?guest_user=Marathi I can see the portal in marathi ... but I cannot change the language.

      But Here to change the language its going to jsp but its not delete actual session and redirect to anonymous language page.

      Please kindly suggest how to delete the actual session and redirect to anonymous language page.