Skip to Content

SAP License issue


Hi,

We have done migration from RHEL 5.9 to RHEL 6.7.

Now hardware key showing at OS level is different then in SAP(slicense).

Also, in license script, H/W key is same as showing @OS level.

When we are applying license in SAP, it is showing "Valid (inactive hardware key)" and also it is not updating the H/W in slicense.

Please let me know, how to sync the h/w key from OS and SAP level.

Regards

Shyam

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Oct 23, 2015 at 01:30 PM

    Hi,

    We have Distributed system. i.e. DB,PAS,ASCS and AAI all are on different host.

    Which h/w key should i use to raise license.

    Regards,

    Shyam

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      The Message Server (running at the ASCS) is the component that determines the hardware key.

      SLICENSE should be showing the same hardware key as you will see in the dev_ms trace.

      If it shows a different hardware key, it would mean that the Dispatcher is connecting to the wrong Message Server.

      In this case, ensure that the parameter "rdisp/mshost" is pointing to the ASCS hostname, and that the service definition "sapmsSID" (at "/etc/services") is pointing to the correct port on all servers of the affected system.

      Regards,

      IsaĆ­as

  • avatar image
    Former Member
    Oct 23, 2015 at 11:58 AM

    Hello Shyam,

    Delete existing licenses in SAP via transaction slicense. Then you need to apply for fresh license via Marketplace for the new hardware key and apply it back.

    Thanks.

    Best Regards,

    Anita

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Anita,

      I have already deleted the old license and temp license.

      Then tried to applied new license but still no luck.

      Still not able to sync h/w key from OS level and SAP level.

      Regards,

      Shyam

  • Oct 23, 2015 at 12:33 PM

    If your hardware key has been changed as part of migration then you need to generate a new license with that hardware key and then apply it. Old license is not going to work.

    Regards,

    Subhash

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 23, 2015 at 12:34 PM

    Have you requested for a new license using the right hardware key?

    First get the hardware key using the command saplicense -get as <SID>adm user

    Request for new license and install it.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 23, 2015 at 12:38 PM

    Hi,

    Yes, i have requested new license and also received the license.

    h/w key is same as i get in slicense -get.

    But, in SAP, active h/w key is diff then license and it is not getting updated after applying the license.

    It is showing message " "Valid (inactive hardware key)".

    Regards,

    Shyam

    Add comment
    10|10000 characters needed characters exceeded