Skip to Content

Disable automatic currency aggregation of key figures in bex query?

Dear Gurus,

we are facing an issue, where we receive value in different transactional currencies for a single company code.

Those records are automatically aggregated by the key figure in our query.

is it possible to disable the Default currency aggregatiob in case that different currencies are used?

As an example this is our view in the Query:

Comp Code Account Value in Transactional Currency 1200 1122330000 * 1200 2211220000 -152.000 USD

we want to get rid of this "*"

This is the view within the InfoProvider in SAP BW

Comp Code Account Value Transactional Currency Key 1200 1122330000 100.000 CAD 1200 1122330000 50.000 USD 1200 2211220000 -152.000 USD

Our query should like this

Comp Code Account Value in Transactional Currency 1200 1122330000 100.000 CAD 1200 1122330000 50.000 USD 1200 2211220000 -152.000 USD

In addition it would be nice if the same logic could be applied to "result rows", but that is only nice to have.

Hope you guys can help me - thanks in advance.

Kind regards

Eric

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 23, 2015 at 10:27 AM

    Hi Greger,

    if the 'transaction currency key' is unit, then add it to rows, this wont allow same account of difference currencies to get summarized .

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 23, 2015 at 10:42 AM

    Hi Greger,

    The ** Value is displayed since the system encountered multiple currencies (Mixed Value )

    If mixed value is encountered system checks the SPRO  Settings


    bex.jpg (48.7 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 23, 2015 at 10:33 AM

    Hi

    this is the way query will work .  In fact the aggregation will take place as per the characteristics we chose. He you have take company code and Account , in query output it will always show as one value

    And since the currencies are different it displays as '*'

    You need to add one more characteristics into the query. Please add the currency key and check if it works.

    Regards

    Priya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 23, 2015 at 10:34 AM

    Hi Greger,

    The aggregation is happening based on the Characteristic which you have added in the Query.

    Hence if is getting aggregated based on the GL account ( irrespective of the currency).

    If you want to get it based on the currency then you have to add the currency in the Query so that this field will split the result based on the currency.

    Please let me know if it works

    Regards

    Vivek

    Add comment
    10|10000 characters needed characters exceeded