Skip to Content

Service notification is not getting closed automatically when set "Do not Execute" for Service Order?

Hi All,

How to close the Service notification automatically when we set the "Do not execute" for a service order. through IW32 when we set the status "ORDER->Functions->Complete->Do not execute", the service order is getting closed but the Service notification linked to this is not getting closed automatically. is it a standard functionality? if it is a standard is there any Exits/BADI s available to achieve this requirement?

Thank you

Regards,

Ramesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 23, 2015 at 10:07 AM

    Hello ram,

    It is a standard behavior. If you want automation, then you need to use user-exit IWO10009 where you will provide logic based on systatus of Order: These are the steps of the program logic to be coded there.

    • Get current Order status through fm 'STATUS READ'.
    • If the status I0015 (Indicates Do not Execute), then
    • Complete the related Notification using the fm 'BAPM_ALM_NOTIF_CLOSE' or 'STATUS_CHNAGE_INTERN'.

    Regards

    KJogeswaraRao

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 23, 2015 at 10:55 AM

    Hi,

    Check BAPI_SERVNOT_CLOSE

    Regards

    Vivek

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 23, 2015 at 11:19 AM

    Ramesh,

    You may have problems trying to close the notification via BAPI when it is already open.

    You can use user-exit IWO10026 (User check on setting status 'Do not perform') to check if the status is valid.

    PeteA

    Add comment
    10|10000 characters needed characters exceeded