Skip to Content

Transport Request Problem

I have encountered a problem regarding transporting role from dev to prd, I have successfully transported the 3 roles but during my last transport it remain running on *truck icon* and it takes forever; tried to close the session and reopen it but and it stuck in a status of copying import queue prd.

System: SAP ECC 6.0

DB: oracle 12c

OS: WS2012R2Std

Please help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Oct 23, 2015 at 12:28 PM

    There should be logs in the transport directory. Check them. If you have terminated the TP processes then make sure the semaphore files (.LOB) are removed. Afterwards remove the transport request from Tx STMS - import monitor for the instance. Finally restart the import

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member James Elvin Hizon

      Hey James,

      With tx SE16 please have a look in table TRBAT.

      Your original transport was stuck and then you have deleted the .LOB file and tried to reimport. For me it looks like the entry in TRBAT was not rolled back due to the above actions.

      If, as I suspect, you will find an entry in TRBAT, please delete the entry and then refresh your TMS queue. It should show as imported then.

      After that, I'd try to import again just to ensure that for the next time everything goes through clean without all the manual intervention you have had to go through up until now.

      Cheers,

      Amerjit

  • Oct 23, 2015 at 08:02 AM

    Hi James,

    Check if you have background work process available in the target system.

    Perhaps all the background work process are busy in the target system.

    Hope this helps you.

    Best regards,

    Martina

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member James Elvin Hizon

      Hi,

      Delete the transport from transport monitor, stop all tp processes from OS and try re-importing again.

      Regards

      Bhargav Bhatt

  • Oct 24, 2015 at 05:35 PM

    Hello James,

    If this behavior of your system is for all the transports and not only the one using which you are transporting roles, then try replacing your tp, r3trans files with latest one.

    I'll suggest to raise an OSS message at same time if issue is for all transports.

    Regards,

    Ashish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 27, 2015 at 08:42 PM

    Hi

    First of all delete ongoing truck i.e request from import monitor

    and u can import manually via command prompt, if the error remains then there may be corruption

    of cofiles and data files during releasing

    manually importing and can use below command:

    1) First add all transports in the buffer with below command:

    tp addtobuffer <transport number> <SID>  pf=/usr/sap/trans/bin/<transport profile>

    2) Then use below tp command to import all requests:

    tp import <transport number> <SID> CLIENT=<client number> u128 pf=/usr/sap/trans/bin/<transport profile>

    Regards

    Shoaib

    Add comment
    10|10000 characters needed characters exceeded