Skip to Content
author's profile photo Former Member
Former Member

can't run ABAP program 'RS_ABAP_SOURCE_SCAN'

Hi expert,

I ran this ABAP program trying to search a string in all abap codes, but message 'string not found' showed up immediately. then I check SU53,

I checked with our security, even granted SAP_ALL, this issue still there. so our security confirmed this is not security issue and the error message is randomly created by cache, means nothing . can you please suggest how to fix this issue?

Many Thanks,

Capture.PNG (8.5 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2015 at 07:45 PM

    S_PROGNAM relates to you and SU53 is your result, but it is not needed as it is a SACF (see the tcode) object and running passively. It is not stopping you from anything.

    What IS stopping you is that the program in which you are searching for the string does not directly contain that string in a static search. Hence string not found...

    If you want to fix this issue you must add the string you are looking for to the code. Or at least a comment in the code. Then it will find it (also with the same authorizations).

    So it is not there. It is now caching either.

    Cheers,

    Julius

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I still place my bets on usage.... but perhaps you can let us know which release and SP level you are on?

      Try this: in the string field enter MESSAGE. In the program name enter SU24_TEST_SWITCH_OFF. Hit F8.

      What happens?

      Cheers,

      Julius

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2015 at 05:59 PM

    Hi expert,

    please help here, if need more information, please let me know.

    Many Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2015 at 06:38 PM

    Thanks everybody, I have to put in '*' to restrict searching area, leaving them blank does not work.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.