Skip to Content
avatar image
Former Member

SAP Portal stops working after popup apears and the session is terminated

Dear Experts, please help me with this issue.

I’ve created some services at SICF, and one of them calls the PR20 transaction. With the following parameters:

~WEBGUI_SIMPLE_TOOLBAR   40

~TRANSACTION               PR20

~TRANSACTIONTYPE     EWT

~WEBGUI           1

~DISCONNECTONCLOSE              1

~POPUPS            1

Note: We’re not using the Webdynpro Abap for the Travel applications due some enhancements that were created at the tCode PR20 / PR05.

During the tests after we save the Trip, appears a Popup with the number of the trip. When we click on OK, the popup continue to be displayed and the logoff page appears at behind. In this situation the portal stops working and we need to refresh the page.

The same situation occurs when we’re using the WEBGUI, and exit the ECC by using the button Logoff à Confirming Logoff.

I’ve already tried:

  • To use the parameter ~POPUPS      0.
  • to redirect the logoff page to the service we’re calling, however it doesn’t work because the application don’t open.

Do you guys have any idea how to treat or correct this issue?

Kind regards!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 29, 2015 at 08:44 PM

    Hi, Siddharth!

    Thanks for your reply! I looked at the topic and when we're redirecting the pages to the service we've founded another problem during the tests.

    We asked help to SAP and we got the solution for this problem.

    We had to upgrade the disp+work on the ECC site to the latest patch level in order to solve the popup problem.

    Thanks again for your support.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 22, 2015 at 08:48 PM

    https://scn.sap.com/thread/3591304 please check here if it helps

    Add comment
    10|10000 characters needed characters exceeded