Skip to Content

Archivelink configuration with an external repository: filenames/types set to file.BIN

Hi all gurus,

I'm quite a newbie on the argument, maybe someone could help me figure out what's wrong in my configuration.

Shortly; we're connecting several backends to a common external repository which supports Archivelink.

To do so, I created an external repository by means of the OAC0 transaction, ARCHLINK type, using an HTTP registry and pointing to the connector (in this case we're using an ACSAP connector provided by IBM in order to store data on a Filenet IS system).

Everything seems to be fine, certificates have been exchanged, connections are fine.

The scenario is as follows: we want to store attachments to a specific inforecord type in this repository. In order to do so we created a ZXY inforecord type, configuring bindings with a certain busobject, and so on.

Now, we access CV01N to create an inforecord of type ZXY... and we are having the following issue: no matter what the filename is, or which MIMEType the file has: on the external repository, the created file has always name "file.BIN" and MIMEType "application/octet-stream".

As a consequence, entries in TOA01 have always the RESERVE field set to "BIN".

Probably we're missing some options in customizing; could anyone help us out to identify the problem?

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 22, 2015 at 11:40 AM

    Hi there,

    can you please give here the used settings from OAC3, OAC2 and OAD2?

    So in the TOA01 entry you'll find a business object type and a document type.

    From this you can find the corresponding OAC3 entry. Also you can check in OAC2 the details of the document type and which document class is assigned to it. Then in OAD2 you can see what is the MIME-Type maintained for the document class.

    What is the scenario in which you're storing the document? Manually with GOS -> New -> Store business document?

    Best regards,

    Janos

    Add comment
    10|10000 characters needed characters exceeded