Skip to Content

Error - Java instance doesn´t start

Hello,

I´m facing one error when I start the Java side of our BW system. This is BW 7.31 with two SAP independent instances, one ABAP and the other JAVA.

I did a heterogeneous system copy of both instances and now, in the new server, the Java instance doesn´t start!

The ABAP is fine, I start the ABAP system without problems, but the Java system doesn´t start, it show me a yellow color in jstart.EXE process as you can see in the following image:

I checked some log files and I see in dev_server0 the following error:

...

M [Thr 5240] Wed Oct 21 17:47:35 2015

M  [Thr 5240] NiInit3: NI already initialized; param 'maxHandles' ignored (init=2;par=32768;cur=2048)

J Wed Oct 21 17:47:38 2015

J  9.492: [GC 9.492: [ParNew: 1051044K->78165K(1223040K), 0.0763132 secs] 1051951K->79072K(4019584K), 0.0764528 secs] [Times: user=0.39 sys=0.05, real=0.08 secs]

M [Thr 5200] Wed Oct 21 17:47:42 2015

M  [Thr 5200] ***LOG Q0I=> NiPConnect2: 172.45.12.13:3600: connect (10013: WSAEACCES: Permission denied) [nixxi.cpp 3283]

M  [Thr 5200] *** ERROR => NiPConnect2: SiPeekPendConn failed for hdl 25/sock 7448

    (SI_ECONN_REFUSE/10013; I4; ST; 172.45.12.13:3600) [nixxi.cpp    3283]

M  [Thr 5200] *** ERROR => MsIAttachEx: NiBufConnect to 172.45.12.13/3600 failed (rc=NIECONN_REFUSED) [msxxi.c      718]

M  [Thr 5200] *** ERROR => LgIAttach: MsAttach (rc=MSENILAYER) [lgxx.c       5189]

M  [Thr 5200] *** WARNING => LgIGroupRereadMs: LgIAttach(rc=-101) [lgxx.c       5338]

M  [Thr 5200] *** ERROR => JRFC> Error jrfc_lg LgGroup failed(-101) [jrfclg.c     384]

M  [Thr 5200] *** ERROR =>       mshost: 172.45.12.13, msserv: 3600, r_group: AENOR_PBI [jrfclg.c     385]

J  Heap

J   par new generation   reserved 1397760K, committed 1397760K, used 298824K [0x000000007fff0000, 0x00000000d54f0000, 0x00000000d54f0000)

J    eden space 1048320K,  21% used [0x000000007fff0000, 0x000000008d76ccd0, 0x00000000bffb0000)

J    from space 174720K,  44% used [0x00000000bffb0000, 0x00000000c4c056f0, 0x00000000caa50000)

J    to   space 174720K,   0% used [0x00000000caa50000, 0x00000000caa50000, 0x00000000d54f0000)

J   concurrent mark-sweep generation reserved 2796544K, committed 2796544K, used 1124K [0x00000000d54f0000, 0x000000017fff0000, 0x000000017fff0000)

J   concurrent-mark-sweep perm gen reserved 1048576K, committed 1048576K, used 64493K [0x000000017fff0000, 0x00000001bfff0000, 0x00000001bfff0000)

F [Thr 344] Wed Oct 21 17:47:42 2015

F  [Thr 344] *** LOG => SfCJavaVm: exit hook is called. (rc = 2150)

F  ********************************************************************************

F  *** ERROR => Java node 'server0' terminated with exit code 2150.

F  ***

F  *** Please see section 'Java program exit codes'

F  *** in SAP Note 1316652 for additional information and trouble shooting advice.

F  ********************************************************************************

F  [Thr 344] *** LOG => exiting (exitcode 2150, retcode 1).

M  [Thr 344] CCMS: CCMS Monitoring Cleanup finished successfully.

That server with that IP address 172.45.12.13 is the old server... before the system copy.

I already checked the SAP JAVA profiles and some parameters in config tool... but unfortunately I don't know where the Java instance have this IP address... in which parameter or setting... I can´t find it 😔

Can you help me please?

Thank you,

JD

SNAG-0184.jpg (31.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 22, 2015 at 12:01 PM

    Hello Joao,

    Please check out this note: 1794176.

    As you can see other log files should be checked as well to determine the exact root cause.

    Best Regards,

    Peter

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      It seems the system when trying to connect to Message server, it fails.

      Please check if message server parameters are properly set (profiles), also check if services file has correct entries in it.

      Go though sap note 2062529

      Regards,

      Prithviraj.

  • avatar image
    Former Member
    Oct 23, 2015 at 06:45 AM

    Hello João,

    Please check the following parameters in default profile and ensure they do not point to old server hostname/IP.

    SAPDBHOST

    j2ee/dbhost

    SAPGLOBALHOST

    j2ee/scs/host

    Try and check for old server hostname/IP in other profiles as well.

    Thanks.

    Best Regards,

    Anita

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      I already solved this error.


      I corrected some data/information connection with some new data that belongs to the new target server and I delete some data that belongs to the old connection. I did that in the config tool at the following path:


      Configurations -> destinations -> RFC -> Propertysheet RFC_TEMP_9


      Here in Propertysheet RFC_TEMP_9 I inserted the following custom-value: UMEBackendConnection


      Then in service com.sap.security.core.ume.service in Propertysheet properties:


      cluster_config -> system -> custom_global -> cfg -> services -> com.sap.security.core.ume.service -> Propertysheet properties

      I changed the value of ume.r3.connection.master.RFCDestination to RFC_TEMP_9 instead UMEBackendConnection.

      Thank you very much for your help,

      BR,

      JD

      SNAG-0066.jpg (197.4 kB)
      SNAG-0109.jpg (202.8 kB)
      SNAG-0068.jpg (230.1 kB)