Skip to Content
author's profile photo Former Member
Former Member

TEXT_SYMBOL_REPLACE replaces the variables in seperate lines

I have a text symbol with variables as below,

Dear &Namev& &Name1&,

When I use the FM 'TEXT_SYMBOL_REPLACE' to replace the texts, it's replaced as

Dear

Archna

Raja

,

The Formatting is lost. How should i overcome this?

I tried even using(C) for the variables. But it doesn't work.

Request your inputs in this regard.

-

Archna

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2015 at 08:59 AM

    Try calling FORMAT_TEXTLINES FM after TEXT_SYMBOL_REPLACE.

    Sample code

    call function 'FORMAT_TEXTLINES'

    exporting

    * CURSOR_COLUMN = 0

    * CURSOR_LINE = 0

    * ENDLINE = 99999

    formatwidth = 128

    * LINEWIDTH = 132

    * STARTLINE = 1

    * LANGUAGE = SY-LANGU

    * IMPORTING

    * NEW_CURSOR_COLUMN =

    * NEW_CURSOR_LINE =

    tables

    lines = ilines. "This internal table is populated by TEXT_SYMBOL_REPLACE . Just pass it as it is

    R

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.