Skip to Content
avatar image
Former Member

CrystalReportPartsViewer

Assembly file version: 13.0.15.1840

Using .NET Framework 4

I am following a tutorial so I can add the CrystalReportPartsViewer to my application.

Binding the Report

I want to set enableParameterPrompt = false;

It says the following:

4. From the Toolbox, open the Crystal Reports node to locate the CrystalReportPartsViewer control.

My issue is I do not see a CrystalReportPartsViewer at all. All I see is the following under Reporting:

Apparently I am supposed to have the "CrystalReportPartsViewer" under reporting. My references are as follows:

Any help would be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 22, 2015 at 09:15 PM

    You don't need the parts. That property is part of the CrystalReportsViewer property.

    Don

    Add comment
    10|10000 characters needed characters exceeded

    • Links for the SDK are on the Overview tab or you can find them by going to help.sap.com

      That doc was for VS 2005, doens't mean it was rolled forward or valid for current versions.

      Current version also hasd RAS available that VS 2005 did not have.

      Samples on the the Overview tab also.

      Don

  • avatar image
    Former Member
    Oct 26, 2015 at 08:36 PM

    Hi Don,

    Thanks again for all your help. Seems like the ReuseParameterValues is the answer to the prompt. I can't say why it was refreshing on me but as soon as I enabled the ReuseParameterValues option, it just took the parameters and has not prompted me since. Thank you so much again for all the help and patience.

    Add comment
    10|10000 characters needed characters exceeded