Skip to Content

Extra blank page in exported MS Excel file

Hi there,

We have a report file which has Main report and one Sub report. And we want to insert a page break per Sub Account Type in subreport.

This is the current settings:

  1. Sub Report >> Section Expert >> Group Header #2 >> Paging tab >> New Page Before >> Formula Workshop >> Added a formula "Not OnFirstRecord" but  "New Page Before" option is not ticked.
  2. Sub Report >> Section Expert >> Group Footer #2 >> Common Tab >> "Keep Together" is not checked
  3. Main Report >> Right Click on Sub Report >> Format Subreport >> Sub Report >> "Supress Blank Subreport" is checked >> we unchecked this option but both did not work..

We want a page break in Group Header #2 level but not a empty page.. Currently row 26 is generated as a blank page as below screenshot.

Could anyone help us for this issue? Users are losing their patience and we need to fix this problem asap.

Thank you in advance.

Appendix 1:

Appendix 2:


1.jpg (109.2 kB)
2.jpg (72.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 27, 2015 at 08:35 PM


    It looks like you're doing the Excel (97-2003) export that includes all of the formatting.  When you export to this format, there should be some additional format options in Crystal.  In particular, make sure that "Create page breaks for each page" is turned off.  If that does not solve your problem, then there is no way to solve it using this export type.  The export is creating the single tall row to take up the rest of the height of the page.  Unfortunately, there is no way to control this from Crystal.  This is the way that it has been since I've been using Crystal (@19 years).

    You could try exporting to Excel Data Only and turning on "Export object formatting" to see whether that will get you what you need.  You'll probably have to play with the "Export page header and footer" and "Simplify page headers" settings.


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Dell,

      Thank you for your professional advice. Yes, we are exporting with all the formatting into Excel. I just double checked "Create page breaks for each page" is not checked, so this is crossed out as a root cause..

      I attempted to export to Excel Data Only with provided options but our end users needs all the format rather than simple formatting. We will play around with the report and keep trying to solve this issue. Thank you again.

  • Oct 23, 2015 at 03:38 AM

    Try using suppress blank sub report, and also suppress blank section on the section containing the sub report ?

    It seems to be inserting one row, but a very large row, which is odd.

    If you remove the page break from the sub-report, does that remove the large empty space?

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Chandresh,

      Thank you for your response.

      We have this sub-report in Group Footer #1b in the main report. We have some other report have sub-report in Group Footer #1 or #2 and they do not have this problem..

      There is one formula under Page tab "Not OnFirstRecord" with the group header 2 in the sub-report but nothing else. When we exported only sub-report in MS Excel, this issue does not happen, so we assume that something is wrong with sub-report setting in the main report.

      As per what steps we tried, please refer to the above comments. I believe I mentioned everything we tried. Thank you.

  • Oct 21, 2015 at 02:53 PM

    Hi Chrissa,

    Could you also post a screenshot of the report's Design page?


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Abhilash,

      Thank you for your quick response.

      Here are the screenshot of main report and subreport in design page.

      Please note that I needed to hide some field and group names  since the report contains confidential information.

      Main Report:

      Sub Report:

      mainreport.jpg (21.7 kB)
      subreport.jpg (168.4 kB)