Skip to Content

Loading Bookmark: Application does not react > Blurred glasspane / transparent overlay

Hi all,

we are using DS 1.5 SP01 Patch 1 on BI Platform and I have problems loading bookmarks since that upgrade.

When loading a standard bookmark with coding such as

Bookmark.loadBookmark(bm_id);

the bookmark is correctly loaded. But the application screen is covered with a transparent overlay and I can't click anywhere, thus the application is no longer usable. Here's a screenshot of the application after I have loaded a bookmark:

The error also occurs in local mode and with both browsers, IE 10 and Chrome 45.

Any idea, why the blurred/transparent overlay does not disappear?

Best regards,

Philipp Hinnah

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 21, 2015 at 02:48 PM

    Hi all,

    I found the reason for the erroneous behaviour:

    All my bookmark related components (e. g. buttons for Load, Save, Share, etc., the listbox with the bookmarks, the input field for bookmark title, etc.) are within a popup component. This popup has the setting "Modal" = true.

    If I switch that setting to "Modal" = false, loading of the bookmarks works as expected without a transparent overlay being shown after loading the bookmark.

    Well, actually the old settings (also with "Modal" = true) worked with DS 1.3, so I basically consider this to be an "error" on SAP side.

    Maybe I should open a message for that... once I got time for this... 😊

    Regards,

    Philipp

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 21, 2015 at 10:22 AM

    Hi all,

    I just found out, that when I share the bookmark and copy the bookmark URL to a new browser window, the bookmark is correctly loaded and there is no transparent overlay.

    Regards,

    Philipp

    Add comment
    10|10000 characters needed characters exceeded