Skip to Content
avatar image
Former Member

schedule report to file system as destination, job success, but no file in the destination

Hi,

I have a crystal report on BI launch pad, I want to schedule this report to destination file system which have access to read and write, the job went to sucess, but there's no file found in the destination file system location.

can you tell me what's wrong?

thanks a lot,

Lola

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Oct 21, 2015 at 11:04 AM

    Hi Lola,

    Please be sure that the following points are met:

    1. Provide the UNC path in the space provided for 'Directory' i.e \\BO servername\shared folder
    2. Provide the username and password of the account which has got the right to

    write files to this directory.

    You need to add the user to the "Allow Logon Locally" policy

    To apply the policy (This must be done on the computer that the Job Server is
    on)

    1. Go to Control Panel->Administrative Tools->Local Security Settings
    2. Expand "Local Policies"
    3. Click on "User Rights Assignment"
    4. Find "Log On Locally"
    5. Right Click on it and select "Properties"
    6. Find the user and add the user

    Note: If you specify a different account when scheduling, then you will need
    to apply this policy to that account instead.

    You can refer to the following SAP articles:

    https://service.sap.com/sap/support/notes/1351820

    https://service.sap.com/sap/support/notes/1262840

    https://service.sap.com/sap/support/notes/2195640

    I hope that this could help 😊

    Best Regards,

    Manoubia

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Lola,

      This is same/easy as FTP settings, however it is getting more difficult in your network.

      Get in touch with your network/windows admins to check the policy for "Allow logon locally" in your network.

      Rather than setting "Allow logon locally" on the machines one by one, this can also be achieved through a domain group policy for all of the hosts in your network.

      ~Swapnil

  • Oct 21, 2015 at 04:12 AM

    Hi Lola,

    If I am not wrong you have changed the file system settings at the report level. Did you check the scheduled report at the directory specified in the file system destination of CR Job server?

    Since you did not get any error, it would be difficult for us to investigate on this. I can see that you have specified a long path in the directory field.

    Could you please change this directory to something like "E:/Reports" and try once again?

    ~SwapnilY

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Lola,

      First, make the host file entry on the BO server for the host name and IP address of the machine where you want to save that file.

      Second, you would need to use the shared path in the directory field of destination.

      e.g. \\IP.IP.IP.IP\FolderName.

      Do let me know if it works for you.

      ~SwapnilY

  • avatar image
    Former Member
    Nov 10, 2015 at 08:16 PM

    Hi Lola,

    Change the " // " to " \\ " in the file destination directory path.  For example file:\\


    Thanks,

    Zach

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 17, 2015 at 07:20 AM

    make the destination server(same domain) firewall allowed connecting by BO server , then it works.

    Add comment
    10|10000 characters needed characters exceeded