Skip to Content

Java failed to start in a dual stack environment

Dear Sir / Madam,

During our annual disaster recovery drill (which try to restore a dual stack netweaver environment from one server to another server, using system copy), We found that the netweaver platform can successfully start off - ASCS, SCS, ABAP server, but failed to start off its Java server.

From "dev.jstart", we see something like :

F  [Thr 10624] *** LOG => Process collector started (pid 7384).

F [Thr 10624] Tue Oct 20 18:07:38 2015

F  [Thr 10624] *** LOG => Process server0 stopping (pid 7320).

F [Thr 8788] Tue Oct 20 18:07:38 2015

F  [Thr 8788] *** LOG => Signal 13 SIGCHLD.

F  [Thr 10624] *** LOG => Process server0 stopped (pid 7320).

F  [Thr 10624] *** WARNING => Node server0 failed: result 1, exit code 2150. [sfxxnode.hpp 1024]

From stdout.server0, we see below :

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 21, 2015 at 02:26 AM

    From stdout.server0, we see below :

    Loading services.

    Calculate startup service set for 198 ms.

      Service [engine.dsr.facade] started. [3] ms / [0] CPU ms

      Service [tc~esi~uddi~content~handler] started. [4] ms / [0] CPU ms

      Service [webservices] started. [4] ms / [0] CPU ms

      Service [engine.lm.log.facade] started. [4] ms / [0] CPU ms

      Service [tc~je~content~classification~handler] started. [0] ms / [0] CPU ms

      Service [tc~je~security~api] started. [3] ms / [0] CPU ms

      Service [r3startup] started. [3] ms / [0] CPU ms

      Service [tc~je~mngt_model~srv] started. [3] ms / [0] CPU ms

      Service [tc~je~cross~api] started. [2] ms / [0] CPU ms

      Service [cluster] started. [8] ms / [0] CPU ms

      Service [runtimeinfo] started. [8] ms / [15] CPU ms

      Service [jmx_notification] started. [11] ms / [31] CPU ms

      Service [timeout] started. [50] ms / [31] CPU ms

      Service [memory] started. [51] ms / [0] CPU ms

      Service [userstore] started. [44] ms / [31] CPU ms

      Service [cross] start ================= ERROR =================

    java.lang.UnsatisfiedLinkError: com.sap.bc.proj.jstartup.fca.FCAProperties.nativeInit(I)V

    at com.sap.bc.proj.jstartup.fca.FCAProperties.nativeInit(Native Method)

    at com.sap.bc.proj.jstartup.fca.FCAProperties.init(FCAProperties.java:54)

    at com.sap.engine.services.cross.fca.FCAConnectorImpl.<init>(FCAConnectorImpl.java:101)

    at com.sap.engine.services.cross.CrossFrame.start(CrossFrame.java:82)

    at com.sap.engine.core.service630.container.ServiceRunner.startFrame(ServiceRunner.java:155)

    at com.sap.engine.core.service630.container.ServiceRunner.startService(ServiceRunner.java:113)

    at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:60)

    at com.sap.engine.frame.core.thread.Task.run(Task.java:73)

    at com.sap.engine.core.thread.impl5.SingleThread.execute(SingleThread.java:175)

    at com.sap.engine.core.thread.impl5.SingleThread.run(SingleThread.java:274)

    FATAL: Critical shutdown with exit code [2150] was requested due to [AS Java cannot be started; core service [cross] failed to start]

    Heap

    par new generation   reserved 419840K, committed 419840K, used 292221K [0x0000000140410000, 0x0000000159e10000, 0x0000000159e10000)

      eden space 343552K,  83% used [0x0000000140410000, 0x0000000151b8c490, 0x0000000155390000)

      from space 38144K,  15% used [0x00000001578d0000, 0x0000000157eb3298, 0x0000000159e10000)

      to   space 38144K,   0% used [0x0000000155390000, 0x0000000155390000, 0x00000001578d0000)

    concurrent mark-sweep generation reserved 1677312K, committed 1677312K, used 39K [0x0000000159e10000, 0x00000001c0410000, 0x00000001c0410000)

    concurrent-mark-sweep perm gen reserved 2097152K, committed 2097152K, used 27258K [0x00000001c0410000, 0x0000000240410000, 0x0000000240410000)

    Any suggestion would be much appreciated !

    Thanks,

    Eric

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 22, 2015 at 02:28 AM

    Please check note Note 1831549:After kernel upgrade to 7.20, AS JAVA does not start due to a shared memory issue

    You may also verify the shared memory parameter or restart the server to clean up and try to start SAP again

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

    • Dear Piyawat,

      Thanks a lot for reminding !

      I have checked the note, the symptom per note mentioned (trace file dev_server0) has ERROR message, which our case did not have.

      As the suggested resolution there state to remove below parm from the profile 

           ipc/shm_permission_62 = xxxxx

      where our profile has no such parm, hence I cannot take a try on the resolution as suggested on the note.

      Anyway, Thanks a lot for your feedback

      Regards,

      Eric

  • Nov 05, 2015 at 08:52 AM

    Dear All,

    Thanks for Roman leading us the direction of checking.

    Finally, we beware the error we committed which leads to the failure

    We follow the DR setup Procedure as prepared by our implemnation consulting firm, without truly understand the System Copy steps in there.

    We finally find that during System Copy step (which we performed on the DR server, where DB image from LIVE server, being restored) the program will check the DR Server Netweaver instance kernel, if there is change, it will - prompt for Kernel Archive location.

    (we still not understand what is the basis to determine Kernel change has happens, and any advice are welcome. In our case, by last year DR drill, we got both LIVE and DR platform sit at 720 EXT PL300, the sapinst.exe which we run system copy step will not ask such question. During this year, we have upgrade both LIVE and DR platform to 720 EXT PL700 - without rerunning the System Copy step again, then the question just pop up)

    If we just press enter to pass over the question, (as recall, we may be just overlook the importance of that question and press [ENTER] key casually without deep thought) the program will try to overwrite the Kernel directory by extractng from its own Kernel Archive.

    After collecting all other question response, the System copy process step kick start, and, Kernel folder is overrided. The mixed EXE / DLL from different version of kernel seems leading to the problem we encountered. (i.e. Java instance cannot start off)

    As we really not beware System Copy not only taking changes on DB content, but also alters files on OS level (i.e. Kernel folder), so once we encounter the issue, we reperform the DB restore again, thinking we may wrongly provide answer to questions raised in the System Copy step. However, the next time while we carry out the steps, as the Kernel folder already overrided, the question about Kernel just no longer appear, and thus all sequence of questions of System Copy step just match with our last year drill. Even though we did not make any mistakes on answering such question this time, we still fail to start off Java isntance.

    This process repeat and repeat again, but the result is still the same.

    As our platform has not much system change throughout this year, and, with Roman's guide on checking direction, we fall back the Kernel to same version (i.e. 720 EXT PL300) which we successfully complete the DR Drill last year, the question is also not ask, but the System Copy steps can successfully finished.

    Then we perform the Kernel upgrade on our DR platform again (resume 720 EXT PL700), and, then carry out System Copy for DR Drill, this time we notice the questions about Kernel Archive folder.

    Having encountered that, We then provide the Kernel Archive (720 EXT PL 700) as used during upgrade. Then the System copy process runs normally and Java instance can start off then.

    We will further study the System Copy process, e.g. refer to the web link as Roman supply, hoping next year DR Drill could proceed much smoothly, if we truly under such step, rather being just a robot to repeat the instruction on DR procedure manual.

    Regards,

    Eric

    Add comment
    10|10000 characters needed characters exceeded