Skip to Content
author's profile photo Former Member
Former Member

oModel read non-english character filter string turn into gibberish code in the backend

I ran into a odd issue, in IE (fine with Chrome), when I perform a oModel read operation (sample code below), the non-english character filter string (this.byId('accountInput').getValue()) got turned into gibberish code (###) in the backend.

Do I need to encode it somehow? Or this is a framework bug?

this.oModel.read("/AccountCollection(accountID='" + this.accountId + "')/Accounts", null, ["$filter=substringof('" + this.byId('accountInput').getValue() + "'" + ",accountName)"], true, fnSuccess, fnFail);

p.s. this.byId('accountInput').getValue() = 'δΈ­ζ–‡'

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 21, 2015 at 03:27 AM

    I'll answer my own question, encodeURIComponent is what I'm looking for 😊

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.