Skip to Content
author's profile photo Former Member
Former Member

HANA Multi-host Replication Certificates


Hana 3 host system version 97
SUSE linux server 11 sp3

I create a system with same topology version 10

Add new system as replication slave,

replication mode: sync

1.) Do Certificates replicate over?

2.) Does all XS engine Content replicate over?

I have been stuck in some old sap cockpit, webdispatcher ui problems during recovery and update process.

I have been updating my hana system and then Recovering and that order of operations is overwriting the updates in xs engine administration UI.

Would replicating over write my xs engine administration ui? /sap/hana/xs/admin OR /sap/xs/admin/webdisptacher/admin ?

Thank you for your time and diligence!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Oct 21, 2015 at 05:12 AM

    Hello Zachary,

    This is what i understand from your post, you have setup system replication between :

    primary system:

    Hana 3 host system version 97 (Revision)

    SUSE linux server 11 sp3

    secondary system:

    Hana 3 host system version 10 (SPS)

    SUSE linux server 11 sp3

    Replication mode: sync primary -> secondary . you should not do secondary -> primary replication, since secondary is higher version than primary.

    1.) Do Certificates replicate over?

    certificate stored in the database will be replicated but not those stored in the file system.

    Certificate Management in SAP HANA - SAP HANA Security Guide - SAP Library

    2.) Does all XS engine Content replicate over?

    yes, XS engine content will also be replicated.



    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Prashanth Bidare

      I performed the fail over process;

      Shot the Primary in the head,

      run sr_failover on Secondary
      Moved Virtual IP to Secondary,


      Moved Primary(Original Primary) to new Virtual Private Cloud AWS(Snap shot, launch instance from snap shot in new VPC; Opened all Ports
      Updated version 100
      Ran Data Sync from third party resource; to "Catch up" , primary and secondary have same data,

      global.ini communication listening .global

      Shot Secondary(Current Primary) in the head,

      Moved Virtual IP to Primary(Original Primary),
      Hana studio Administration Console showing no data, only maintains REFRESHing state.

      CAN see tables, CAN query data.

      No cockpit administration, no xs admin

      all services running but something was funny on HDB info


      \_ /usr/sap/H2D/HDB00/imdbmasterslave/trace/hdb.sapH2D_HDB00 -d -nw -f /usr/sap

      h2dadm 3551 3324 0.2 13022284 1597316 \_ hdbnameserver

      h2dadm 3963 3324 0.1 2891192 435968 \_ hdbcompileserver

      h2dadm 3967 3324 0.1 2817276 453060 \_ hdbpreprocessor

      h2dadm 3991 3324 2.9 55411612 52010500 \_ hdbindexserver

      h2dadm 3993 3324 0.2 4318588 1175408 \_ hdbscriptserver

      h2dadm 3995 3324 2.4 10413092 7480128 \_ hdbxsengine

      h2dadm 4693 3324 0.1 3203748 518232 \_ hdbwebdispatcher

      But the server in question had the hdbindexserver branching from hdbcompileserver?

      Moved Virtual IP back to Seconday.

      Attempted process again with Original primary before the snap shot
      no success

      Current state:

      Secondary(Current Primary)
      Primary( Original, after snap shot in AWS VPC)


      So my question is: Is this probably a networking issue? Hana internal routing holding the original private IP used for internal communication during hana install?

      I updated /etc/hosts with proper internal ip.
      hostname is also the same.

      Tried; sr_unregister -force
      Tried; sr_disable
      ERROR: Host has registered slave

      Any ideas would be appreciated,
      Thank you for your diligence,

  • author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2015 at 08:13 PM


    After setting up the SYSTEM Replication you will notice the list of volumes that are replicated from TIER1 to TIER2 in the LANDSCAPE-->SYSTEM REPLICATION tab

    The data contained in all these volumes is replicated and available on the TIER2, that would give you a better picture of the System Replication services

    Hope this helps


    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Prashanth Bidare

      That was helpful thank you..
      He did not mention stopping the primary..
      I therefore jumped to conclusions..
      Thank you.

      The primary can continue to run and it will reconfigure itself after take over is complete, then I can take it off line to add hosts and distribute data and catch up to the secondary.. then do the switch since it cannot be a secondary, as it will not have equal number host.


Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.