Skip to Content
avatar image
Former Member

Custom object vs Role transport dependency

Hi Experts,

We built a custom auth object which got  transported to QA before PFCG role but still the PFCG role is not generated via transport. Role is fine in Development.

Can anyone please advise if there is really a dependency between custom auth object and PFCG role ? if yes, which should be transported first ?

PS: Authorization data contains custom auth object in the PFCG role in both Dev and QA except the profile is not generated in QA.

Regards,

Salman

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 21, 2015 at 12:23 AM

    Hi Salman

    You'd want the new object moved first (just like a new transaction)

    When you transported the role did you include the generated profile? What happens if you attempt to generate profile directly in QA?

    Regards

    Colleen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2015 at 12:52 AM

    Hi Salman,

    I presume the profile will be generated if the authorization object has not been moved into QA initially with the corresponding object as inactive. Do let us know what is the result of profile generation.

    Regards,

    Mayur

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2015 at 12:54 PM

    Hi Colleen/Mayur,

    Yes, we moved the auth object and custom t-code first then moved the role. Yes, we included the role in the transport after generating in development and selected the option "include generated profiles for single roles"

    I generated the role in QA and it turned green which is fine but not sure why it is not automatically turned green via transport?

    We transport roles almost every week like this for custom t-codes but this is the first time we created custom auth object as well.

    Regards,

    Salman

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Salman,

      I am curious of community members answers as this happened to me once. After you generated directly in QA, was the PRD import successful or did you need to generate in that environment also?

      Have you taken a look at TMS in QA and checked that there were no warnings or errors with custom auth object & t-code import? Please check the auth object & t-code import as I found my answer in the message to having to regenerate profile directly in QA.    

      Thanks,

      Patrick

  • avatar image
    Former Member
    Oct 21, 2015 at 07:02 PM

    Hi Patrick,

    I collected the role in a fresh transport again and released for QA and PRD and it worked fine. (role is green automatically)

    But I am still not clear why it didn't generated with the first transport. It happened twice (with different custom objects).

    We always move our custom auth objects/t-codes first then move our PFCG role transport.

    Regards,

    Salman

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Salman,

      as Patrick wrote before: next time it happens, check the import log. In case the overall RC of the import was not 0, expand all nodes of the log completely to find the corresponding warnings....

      b.rgds, Bernhard