Skip to Content

SMP3.0 SP09 PL01 - Oracle Driver Not Found

Hi all,

After a failed attempt to get SMP3.0 to consume a SOAP WS, I'm about to try to directly consume an Oracle DB.

I've followed several tutorials on how to setup the SMP to consume the Oracle DB, after creating the Destination configuration for the Oracle DB, I get the following message: "Connection test failed - Driver class oracle.jdbc.driver.OracleDriver not found".

I already followed several possible fixes for this issue:

I've tried the ojdbc6.jar and ojdbc7.jar. I've tried the generated bundle from eclipse and SMP "create_jdbc_bundle.bat", I've tried to put it directly in the Server\lib folder and also in the pickup folder.

Can anyone explain me why after following all the above tutorial, SAP note and discussion I can't get it to work?

Best regards,

Vicente

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 28, 2015 at 08:28 PM

    Thanks Vicente for sharing this solution. Copying solution to those don't have access to Market place:

    Cause of this question: after adding the sqljdbc4.jar into server\lib the service needs to be re-generated to reflect the CLASSPATH change for it.

    Resolution

    1. Stop the SMP processes and delete the contents of ${MobilePlatform3}\Server\configuration\org.eclipse.osgi\*
    2. Copy the sqljdbc4.jar into server\lib dir.
    3. Re-generate the SMP services.
      a)      Stop all the smp service/processes and ensure that there are no java processes running for SMP.
      b)      In a DOS command window, go to the server\bin directory.
      c)      Run:  svcutil.bat -uninstall
      d)      Run:  svcutil.bat -generate
      e)      Run:  svcutil.bat –install

    Regards,

    JK

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 20, 2015 at 03:22 PM

    Did you also try with command line as below? What output do you see?

    command line also helps you in converting JDBC JAR to OSGi JAR to use with Integration Gateway in SMP

    F:\SAP\MobilePlatform3\Server\tools\dbconfig>create_jdbc_bundle.bat -oracle C:\temp\ojdbc7.jar

    Add comment
    10|10000 characters needed characters exceeded