Skip to Content
avatar image
Former Member

DSO to Cube loading is very slow

Hello Experts,

I have one DSO which has more than 16 million entries and it took around 1 hour to load from PSA.

However when I am trying to load it to Cube from DSO it taking very long to finish.

I am loading fiscal year wise but then also for 2 million entries its taking very long time and not finishing.

Is there any solution for this?

This is first time this cube is getting loaded.

index has been dropped before loading.

there is no routine in the transformation.

Could anyone suggest something here?

Regards,

Ankie

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Oct 20, 2015 at 02:32 PM

    Is the DSO indexed on Fiscal Year? Is Fiscal Year the first column of the key fields of the DSO? If the answer to both those questions is "No", then performance is likely to be slow. In this case it doesn't matter whether it's pulling 2 million records or 2000, it's doing a full table scan both ways and that takes time.

    The other thing that can kill performance is Semantic grouping in the transformation/DTP. If there are any, and again if those are on non-indexed or non-key fields of the DSO they performance will be poor. Try to cut down on them if possible.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Suhas,

      There is no semantic group in DTP.

      However fiscal year is not present in the key field section. its in data fields in DSO.

      Regards,

      Ankie

  • avatar image
    Former Member
    Oct 20, 2015 at 02:29 PM

    Hi Vivek,

    Default size has been put as 50000 for this DTP.

    will it help if I increase the size of data packet?

    We have 15 background process assigned to this DTP.

    Regards,

    Ankie

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2015 at 02:54 PM

    Hello,

    I have attached the file.

    Please take a look.

    all packages are doing the same.

    Regards,

    Ankie


    Cube.PNG (23.5 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ankie,

      Could you please increase the number of process in the "Batch manager settings" in the DTP level and decrease the data package size.

      Regards

      Vivek

  • Oct 20, 2015 at 03:06 PM

    2.Hi,

    1.increase the parllel process at the DTP .

    select go to menu -> select setting for DTP batch manager -> increase the process.

    2. decrease the data packet size -> 30,000 under extraction tab.

    3. check the symantic group options.

    4. before loading the data first delete the index and after loading create the index again.

    Thanks,

    Phani.

    Add comment
    10|10000 characters needed characters exceeded