Skip to Content

Issue with IDOC_AAE Receiver channel configuration

Hi Experts,

After going through many unanswered blogs with same issue , I am opening a new thread.

I am working on a migration project and the interface is working fine in production(PI 7.1). But, testing the same interface in PO Sandbox(7.4) system is showing errors as mentioned below -

Error if configuring through NWA -

Transmitting the message to endpoint <local> using connection AFW failed, due to: com.sap.aii.af.idoc.exception.IDOCAdapterException: IDoc: Connection factory name for channel CC_IDOC_R_Common is null


Error if configuring Manually -

MP: exception caught with cause com.sap.aii.af.idoc.exception.IDOCAdapterException: Sender Partner Number is not available


**Points to be noted while analyzing the issue are mentioned below. Please go through and give your inputs -

1) Compared the payload of Production(7.1) and Sandbox(7.4), Output payload is getting generated and everything seems to be fine in mapping. In Sandbox, the control records are coming in the payload along with the generated IDOC. In Production, control records are not coming in output payload.


2) Added the component in header mapping in Sandbox, same as in Production. (INTEGRATION_SERVER_XXX)


3) Changed the property of JavaIdocAdapter in NWA, default sender port set to the port created in we21 in ECC system. Is this correct? or we need to put port of system? (mentioned in one of the SAP notes)


After trying many options mentioned over scn, still I am unable to resolve this issue.

Please guide me to solve this issue.

Thanks,

Nidhi Srivastava



Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Oct 21, 2015 at 07:35 AM

    Hi,

    Hello,

    If you think there's some issue with the outboundRA, then could you please check once your JCA Connection Factory Details:

    NWA->Configuration->Infrastructure->Application Resources:

    Under ResourceName: outboundRA -> select one with Resource Type as JCA Resource

    Below you'll be able to see your receiver comm. channel under the Related JCA Conn. Factories tab

    Select your comm. channel and check the JCA Conn. Factory Details. Under Configuration Properties your target destination must be maintained.

    Also, check the outboudRA (Resource Adapter Type), setting should be as below:

    Also, in case of Manual, Under Advanced tab: IDoc Control Headers -> Tick Override IDoc Control Headers -> Under Header/Value -> Maintain the SNDPRN and value as sender logical system..Not sure but try it..


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 21, 2015 at 02:03 PM

    Issue solved.

    • Adding the Override IDOC header - SNDPOR & SNDPRN in receiver communication channel.
    • Adding Logical system value in SLD Business system(sender component).

    Thanks,

    Nidhi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.