Skip to Content

Error DI to SAP Business One 9.1

Dear all,

I have some code to DI some information to SAP Business One 8.82, and it's succeed.

Then, because of some needs, I have to upgrade my SAP Business One into version 9.1.

It means that I should change my SAPBobscom and SAPBobUIcom.

After changing it, this error comes out :

Retrieving the COM class factory for component with CLSID {632F4591-AA62-4219-8FB6-22BCF5F60090} failed due to the following error: 8007007e The specified module could not be found. (Exception from HRESULT: 0x8007007E).

Anyone ever had the same error?

And how to solve this?

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 22, 2015 at 11:12 AM

    Hi Marini,

    1) Uninstall old DI API & clear registry then restart your system.

    2) Install DI API 9.0 x86 & x64. then in code add reference SAP Business One DI API Version 9.0 & SAP Business One UI API Version 9.0

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2015 at 04:19 AM

    Have you tried to removed the current reference in your project and add again? Then Debug > Clean > Build

    Also, please install the x86 DI API in your machine.

    Regards,

    Bry

    Blog: http://www.sap-tips-tricks.com/

    Add comment
    10|10000 characters needed characters exceeded