Skip to Content
avatar image
Former Member

No data found in BODS

Hi there,

My team just prepared a new DS server to develop the data service project. For practice, I created a simply data flow to load data from a ERD to a table in SQL data warehouse. I executed the job and it completed without error. But there is no data pull out from source to target. No data from "View Data"  in Source object, either. I searched the forum and someone posted a solution as "Execute BODataView.ocx        and BODiffCtrl.ocx file from the Command Prompt. However, it didn't solve this problem after I use Regsvr32 to execute those two files. Any other suggestions? Thanks!

Cindy

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 29, 2015 at 08:56 AM

    Hi Cindy,

    1.Please try to open the data service designer window with admin access(Right click and Run as administrator) every time.

    2.Please Open Command Prompt with admin access(Run as administrator) and execute the below commands.(Permanent solution)

    regsvr32.exe "%LINK_DIR%\bin\BODataView.ocx"


    regsvr32.exe "%LINK_DIR%\bin\BODiffCtrl.ocx"



    This will work for sure😀



    Thanks,


    Sagar T


    ds.png (8.1 kB)
    cmd.png (4.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2015 at 03:35 PM

    ok , looks like there are no records source table.

    1.Make sure the source data store points to the right DB

    2.In source Database , run a SELECT * FROM statement on the source table to see if there are records.

    Add comment
    10|10000 characters needed characters exceeded