Skip to Content
avatar image
Former Member

HANA DBACockpit unable to load GROUPS... After upgrade...

Hi,

I upgraded our HANA System from 1.0. SP9 (R. 090) to 1.0 SP10 (R. 102).

We had a lot of Warning with some DUs:

... 

Command line is: /usr/sap/LVL/HDB00/exe/regi --verbose --workspace=empty --host=frparlbox0:30015 --user=SYSTEM --readFromStdIn import /usr/sap/LVL/global/hdb/auto_content/HANA_XS_BASE.tgz

CTIVATION ERROR: object: "SECURITY_QUESTIONS.hdbti", package: "sap.hana.xs.selfService.user.db", timestamp: 2015-10-02 11:19:20.3790000

sap/hana/xs/selfService/user/db/SECURITY_QUESTIONS.hdbti: code 40401: Invalid runtime schema version.  Need at least a consistent version 17 of schema _SYS_RT

Command line is: /usr/sap/LVL/HDB00/exe/regi --verbose --workspace=empty --host=frparlbox0:30015 --user=SYSTEM --readFromStdIn import /usr/sap/LVL/global/hdb/auto_content/HANA_XS_LM.tgz

ACTIVATION ERROR: object: "permissions.hdbti", package: "sap.hana.xs.lm.hanaCockpit", timestamp: 2015-10-02 11:21:58.8380000

sap/hana/xs/lm/hanaCockpit/permissions.hdbti: code 40401: Invalid runtime schema version.  Need at least a consistent version 17 of schema _SYS_RT

I tried to reimport the DU manually: same  

Our HANA System running but the DBA Cockpit can't runs after the login page. We have the error: Unable to load groups

     -> started from DBA studio or directly with the link (http://<HANABOX>:<PORT>)/sap/hana/admin/cockpit)

I found some Notes but not resolve my Problem...

I see that a lot of Privileges not imported

If i compare the Schema _SYS_RT from our HANA System with another HANA System (1.00 R. 102), there a lot of tables missing...

see attach file (our _SYS_RT schema)

Our HANA System is in Production Internally for some Project... (we have installed it there are 3 years ago with 1.00.28 and some upgrade and migration... )

Could i import the Schema _SYS_RT from another HANA System with same Release (fresh install) ?

Do you have more idea?

Thanks for advance for your help 😊

Best regards,

Rico

table_SYS_RT.jpg (26.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Nov 05, 2015 at 12:32 PM

    Hi Rico,

    we got the same issue after upgrade to 1.0 SP10 (R. 102).

    Please try this:

    First, the user that should login to HANA Cockpit need the following roles (2149157):

    sap.hana.admin.roles::Administrator

    sap.hana.admin.roles::Monitoring

    The second point could be your saved favorites in your browser. The content of the HANA Cockpit link changed. So if you change the calling link at the end from

    "...?siteId=sap|hana|admin|cockpit|cockpit" to "...?siteId=sap|hana|admin|cockpit|app|cockpit"

    the link should work.

    Please try.

    Best regards

    Torsten

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear Jerry,

      our HANA-cockpit link is a little bit longer and it works for us:

      <host>:<port>/sap/hana/uis/clients/ushell-app/shells/fiori/FioriLaunchpad.html?siteId=sap|hana|admin|cockpit|app|cockpit

      best regards

      Torsten

  • avatar image
    Former Member
    Nov 15, 2015 at 07:39 AM

    Hello Rico,

    I had experienced the same issue after upgrading from v92 to v102. Can please let me know if you would have solution?

    Thank you

    Jerry

    Add comment
    10|10000 characters needed characters exceeded