Skip to Content
0
Former Member
Feb 09, 2006 at 10:50 PM

Problem in Outbound IDOC

105 Views

Scenario: R/3(IDOC) ->XI ->File share (normal xml file).

File Share (available in a separate WINNT Server) is defined as a Business system in SLD

Partner Profile is created under “KU” in the sender R/3. There are multiple partner profiles maintained for each dealer. So the <RCVPRN> value will vary depending on the dealer.

<EDI_DC40 SEGMENT="1">

<TABNAM>EDI_DC40</TABNAM>

<MANDT>030</MANDT>

<DOCNUM>0000000000707087</DOCNUM>

<DOCREL>46C</DOCREL>

<STATUS>30</STATUS>

<DIRECT>1</DIRECT>

<OUTMOD>2</OUTMOD>

<IDOCTYP>ORDERS05</IDOCTYP>

<CIMTYP>Z1TDORDERS05_EXT</CIMTYP>

<MESTYP>ORDRSP</MESTYP>

<STD>X</STD>

<STDVRS>004010</STDVRS>

<STDMES>855</STDMES>

<SNDPOR>SAPD20</SNDPOR>

<SNDPRT>LS</SNDPRT>

<SNDPRN>D20030</SNDPRN>

<RCVPOR>D01010_XI</RCVPOR>

<RCVPRT>KU</RCVPRT>

<RCVPFC>AG</RCVPFC>

<RCVPRN>0006036041</RCVPRN>

<CREDAT>20060208</CREDAT>

<CRETIM>171944</CRETIM>

<SERIAL>20060207095859</SERIAL>

</EDI_DC40>

The Problem is

When an IDOC is sent from R/3 to XI I get the following error: “Party and service not defined”.

Trace Reveals this:

<Trace level="2" type="T">party-scheme: ALE#KU#AG</Trace>

<Trace level="1" type="T">party normalization error: scheme = ALE#KU#AG</Trace>

<Trace level="2" type="T">Set Sender Routing-object </Trace>

<Trace level="1" type="T">Set Receiver Routing-object </Trace>

I’m using service without Party in the Integration Directory.

Kindly help me to resolve this problem.

regards,

Sundararamaprasad.