Skip to Content
avatar image
Former Member

Navigation to application from email content

Hi Everyone,

We have created a UI application with the following application URL and hosted it an Extranet portal used within the organization.

https://xxx.xxx.xxx.org:8050/sap/bc/ui5_ui5/sap/zui_tool/index.html#/

We used ng-route (Angular JS routing) such that users will be able to access

https://xxx.xxx.xxx.org:8050/sap/bc/ui5_ui5/sap/zui_tool/index.html#/create

to go in create mode and,

https://xxx.xxx.xxx.org:8050/sap/bc/ui5_ui5/sap/zui_tool/index.html#/view

to go in view mode.

The tool is integrated with the backend system and triggers a workflow. The workflow will send out an email to certain agents with the 'view' link embedded in the email content.

However, when the user clicks on the link (in SAML enabled environment), then the user goes to the site,

https://xxx.xxx.xxx.org:8050/sap/bc/ui5_ui5/sap/zui_tool/index.html#/

instead of going to the 'view' page. The weird part is, when they click on the same link again(without closing the first instance of the application), the page opens correctly in 'view' mode.

We also tried another scenario wherein we opened the Intranet irj/portal link and then clicked on our application view link from the email content. The page opens correctly in the 'view' mode at the first instance of clicking the link.

It looks like some issue with authentication. However, we are not able to ascertain why the tool opens correctly when the same link is clicked only twice and not once.

Request your advise.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Oct 31, 2015 at 11:20 AM

    Rootcause found. Solution being implemented.

    Add comment
    10|10000 characters needed characters exceeded