Skip to Content
avatar image
Former Member

Error FWM 02127 when generating a certificate for SAP HANA Authentication

Hi All,

I'm trying to configure SAML SSO from SAP BO to SAP HANA and has completed the SAP HANA part. However, when I try to generate certificate for SAP HANA in SAP BO CMC, I get the following error:

Failed to generate the certificate due to: A random object must be specified for RSAKeyPairs.. (FWM 02127)

I get this error while doing the following, CMC >> Applications >> HANA Authentication. Add the hostname, port and unique ID. When I click on GENERATE, I get that error.

Has anyone seen this error before or has an idea on how to solve this? If yes, can you please share how to solve this? Thanks a lot.

Robert Camangon

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 19, 2015 at 10:55 AM

    Hi Robert,

    Can you please check below KBA.

    http://service.sap.com/sap/support/notes/2199844

    Regards,

    Hrishikesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I saw this note while looking for a solution yesterday but this is not the same issue that I have. This talks about a NW system and a BO system which we currently don't have. Thanks for the help though.

  • avatar image
    Former Member
    Oct 19, 2015 at 03:38 PM

    Hi Robert,

    Can you specify please which version do you have?

    We have encountered this issue with some customers, we could generate the key without any issue after upgrade to BI4.1 SP5.

    Best Regards,

    Manoubia

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Manoubia,

      Thanks for the help, we are currently at 4.1 SP5 though. I found a workaround for the issue which is to login to the web server and access CMC from there. Using that, I was able to generate the needed keys and was able to proceed.

      Generating certificates normally is still an issue though so I opened an incident with SAP. I'm hoping they have a solution for the issue.

      Thanks,

      Robert