Skip to Content

Attachment missing in My leave request (Version 2)

Hi Experts,

I have implemented My leave request & Approve leave requests (Version 2). Application component are UIHR001 & GBX01HR with latest patch level. My environment is embedded.

My query is: When I create leave request with an attachment it show success message and approve got the same request as well but attachment is not there. When I see in my leave history the attachment is also not there.

I can see in App extensibility:

HCM_S_LRQ_FILE_ATTACHMENT

HCM_S_LRQ_FILE_ATTACH_INCL

Allows you to extend the File Attachment entity

But don't know how to use or implement it as I am not an ABAPer. It would be highly appreciable if guide me step by step.

Regards,

S Pandey

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 18, 2015 at 03:49 PM

    Hi Shakti;

    Check if following notes are helpful.

    2149581

    2148358

    2143006

    Regards,

    Sarbjeet Singh

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 19, 2015 at 05:22 AM

    Hi Shakti,

    Please check if you can find any errors in console of browser(F12) or /iwfnd/error_log in Gateway when creating leave with attachment or not?

    Regards,

    Lynn

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Lynn,

      I am not getting any error, neither in console of browser(F12) or /iwfnd/error_log. I am able to create request and processor is also able to approve/ reject leaves but neither employee nor manager able to see the attachment as there is no attachment tab.

      Regards,

      S Pandey