Skip to Content
avatar image
Former Member

Cannot save Links in Database Export

I am using Crystal Reports 2013.  I just add a an additional table in my report and I tried to establish a link to the new table.  I saved it but everytime the link I saved has disappeared.  My question is :

1.  Can I only establish link using primary key or secondary key in the link?

2. If I tried to establish link between 2 tables but the field is not part of the key, is there any way I can establish the link?

3. When I saved my link.  Crystal Reports never given me any error.  So I though the link I established is ok.  But it disappeared everytime I check back.  If I can not establish link without using key, then Crystal Reports should have error message appears and warn me.

Any idea of how to fix this problem?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 19, 2015 at 09:11 PM

    Hi Ronnie,

    Maybe the client is not capable of using un-keyed fields. Have you verified what you are doing is valid using the you DB SQL tool?

    If you show SQL after you add the link in CR designer do you see its reference?

    If you do copy the SQL and create a new report and connect and then use a Command and paste it the SQL. Does that work?

    What database are you using and how are you connecting? Have you tried using ODBC or OLE DB or Native? Could be a problem with the client....

    You need to do more testing...

    Don

    Add comment
    10|10000 characters needed characters exceeded